summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-28 18:48:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-28 19:01:46 +0200
commit251669b3955b845ac4bcef9f1ed3b655a9f6a5b8 (patch)
treecc62cbc155dc047643029aaec21c51a3fd81ed13 /dev-ros
parentdev-ros/image_view: add missing dynamic_reconfigure dep. (diff)
downloadgentoo-251669b3955b845ac4bcef9f1ed3b655a9f6a5b8.tar.gz
gentoo-251669b3955b845ac4bcef9f1ed3b655a9f6a5b8.tar.bz2
gentoo-251669b3955b845ac4bcef9f1ed3b655a9f6a5b8.zip
dev-ros/python_qt_binding: backport upstream fix
For building qt_gui_cpp. Closes: https://bugs.gentoo.org/691860 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/python_qt_binding/files/var.patch31
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.5-r1.ebuild (renamed from dev-ros/python_qt_binding/python_qt_binding-0.3.5.ebuild)1
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/python_qt_binding/files/var.patch b/dev-ros/python_qt_binding/files/var.patch
new file mode 100644
index 000000000000..f0cd56d10a7e
--- /dev/null
+++ b/dev-ros/python_qt_binding/files/var.patch
@@ -0,0 +1,31 @@
+From 1b3000d2eccfad651b427de20028a4ca552e9ea7 Mon Sep 17 00:00:00 2001
+From: Hans Gaiser <h.gaiser@fizyr.com>
+Date: Mon, 29 Jul 2019 15:17:39 -0700
+Subject: [PATCH] Replace Qt variable in generated Makefile. (#64)
+
+* Replace Qt variable in generated Makefile.
+
+* use single quotes
+---
+ cmake/sip_configure.py | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/cmake/sip_configure.py b/cmake/sip_configure.py
+index 49eb866..ce084dd 100644
+--- a/cmake/sip_configure.py
++++ b/cmake/sip_configure.py
+@@ -145,5 +145,14 @@ def split_paths(paths):
+ else:
+ makefile.extra_cxxflags.append('-std=c++14')
+
++# Finalise the Makefile, preparing it to be saved to disk
++makefile.finalise()
++
++# Replace Qt variables from libraries
++libs = makefile.LIBS.as_list()
++for i in range(len(libs)):
++ libs[i] = libs[i].replace('$$[QT_INSTALL_LIBS]', config.build_macros()['LIBDIR_QT'])
++makefile.LIBS.set(libs)
++
+ # Generate the Makefile itself
+ makefile.generate()
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.5.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.5-r1.ebuild
index 5309c2893fbe..f74ff22c2b2e 100644
--- a/dev-ros/python_qt_binding/python_qt_binding-0.3.5.ebuild
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.3.5-r1.ebuild
@@ -18,3 +18,4 @@ RDEPEND="
dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/var.patch" )