summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-08-03 06:46:45 +0200
committerHans de Graaff <graaff@gentoo.org>2021-08-03 06:54:08 +0200
commitd53c90d9cb016cf2125b69e19fe7e4f9ad85121f (patch)
treed94bae77e1b28407acd3361c2de92e3876e9936d /dev-ruby/autoprefixer-rails
parentdev-ruby/globalid: add 0.5.2 (diff)
downloadgentoo-d53c90d9cb016cf2125b69e19fe7e4f9ad85121f.tar.gz
gentoo-d53c90d9cb016cf2125b69e19fe7e4f9ad85121f.tar.bz2
gentoo-d53c90d9cb016cf2125b69e19fe7e4f9ad85121f.zip
dev-ruby/autoprefixer-rails: add 10.3.1.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/autoprefixer-rails')
-rw-r--r--dev-ruby/autoprefixer-rails/Manifest1
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-10.3.1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/Manifest b/dev-ruby/autoprefixer-rails/Manifest
index 17709c75eacf..8a4ba0587333 100644
--- a/dev-ruby/autoprefixer-rails/Manifest
+++ b/dev-ruby/autoprefixer-rails/Manifest
@@ -1,3 +1,4 @@
DIST autoprefixer-rails-10.2.5.0.tar.gz 705265 BLAKE2B e6619cb2498eed46af1e92855e960e74f443c364d5d9c11b839e114bbd97797b90c2f6c6180ae68ba291b0035c1ef24f85d7dadfe07f236c6a611e0fe602bcca SHA512 8b3e80c61735d509e4448887272f2b9304ad1431ad4728a524fc87f096822bd10b6855bd1184943037ba2d10920a0fb1b16d09c8124d023b4edb7e9d1b9fb269
DIST autoprefixer-rails-10.2.5.1.tar.gz 705267 BLAKE2B 089e4bbd8a2acadd7f07a2b3ea5bfdf77b6e83a35a1fdaf55deadf26a8a2e6ca0777c834c300d75877a38cdb10542dab4661dfcb0008c0cbe54c14741a6390be SHA512 97388b55fa0d3df72525c82c105307cd1bd9009e6bcfe161b218f40e1a6508f9c470b990164cbdb2b3c2cac13dc88628c24c3620f814eccbc5de0407536c84f6
+DIST autoprefixer-rails-10.3.1.0.tar.gz 1357327 BLAKE2B 2071b3a9c5848e06695e32445224f6e101481fac0ca73a23b86d138bfada9f7339bd51031f121ab8b0f614d2ea1ec386cb81dbbcf8f728075b12ff2393c0c8b5 SHA512 fff90cad950228e9d3b61259f26bee26b2fe3cd87557ed81f1235630357204e3cf9ce6cc9439551727d4d62d27f3510c8c2683ab12b05ad11549945f741e5db5
DIST autoprefixer-rails-9.8.6.5.gem 231936 BLAKE2B 7c702f5484f9aa2318408fb8c5c8866ccf9d3565d3282e43279b9bea875ac3610b26c0ec302b2bed0779dcd46eca12badaa16faba1046585cddcfa3e8b22b51c SHA512 6b7281661fcaf0c17ee258a321f8d18664f2f305172719f76fe1f3ef6b04fa1460c7102946e95153df7ecf5c3ade3bfc8c22d302927f2e2183ef3b0f3ef8d623
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.3.1.0.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.3.1.0.ebuild
new file mode 100644
index 000000000000..efaf80056df3
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.3.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+RUBY_FAKEGEM_GEMSPEC="autoprefixer-rails.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+SRC_URI="https://github.com/ai/autoprefixer-rails/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/execjs"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rails-5.0.0
+ dev-ruby/rake
+ dev-ruby/rspec-rails
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/ s:^:#:" \
+ -e '/config.sass/ s:^:#:' spec/app/config/application.rb || die
+ rm -f spec/rails_spec.rb || die
+}