summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/imagesize
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/imagesize')
-rw-r--r--dev-ruby/imagesize/Manifest1
-rw-r--r--dev-ruby/imagesize/imagesize-0.1.1_p20100902-r1.ebuild28
-rw-r--r--dev-ruby/imagesize/imagesize-0.1.1_p20100902.ebuild28
-rw-r--r--dev-ruby/imagesize/metadata.xml8
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-ruby/imagesize/Manifest b/dev-ruby/imagesize/Manifest
new file mode 100644
index 000000000000..11209ffe7ea0
--- /dev/null
+++ b/dev-ruby/imagesize/Manifest
@@ -0,0 +1 @@
+DIST imagesize-0.1.1_p20100902.tar.gz 77378 SHA256 c88a25503d7ac5e45491ee0408b411bda0d1f303d308f6a7286123e1764fc629 SHA512 62f0b5d1330e5cc63cccfed79e6aaa4c9de0b2d3598d241c143067c3811788bec14128d2f2465b802b91b428c239c3df272523e3026930ce26da8c7b04c2d55b WHIRLPOOL 56ce4d3c8b540317f0ada374e5ff5401d74b6b91ed5da5e70936576310f0beab1b3f328a7ace1d3458506420133574337bc06aed4bc8ee83e6562b331a230e7d
diff --git a/dev-ruby/imagesize/imagesize-0.1.1_p20100902-r1.ebuild b/dev-ruby/imagesize/imagesize-0.1.1_p20100902-r1.ebuild
new file mode 100644
index 000000000000..7ebfd30a0803
--- /dev/null
+++ b/dev-ruby/imagesize/imagesize-0.1.1_p20100902-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+RUBY_FAKEGEM_VERSION="0.1.1.20100902"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Measure image size (GIF, PNG, JPEG, etc)"
+HOMEPAGE="http://imagesize.rubyforge.org/"
+COMMIT_ID="bd5be2afb088beba3f0d863cef4eac7db56ca804"
+SRC_URI="https://github.com/mattheworiordan/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RUBY_S="${PN}-${COMMIT_ID}"
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S test/test_image_size.rb || die
+}
diff --git a/dev-ruby/imagesize/imagesize-0.1.1_p20100902.ebuild b/dev-ruby/imagesize/imagesize-0.1.1_p20100902.ebuild
new file mode 100644
index 000000000000..35630cef24a5
--- /dev/null
+++ b/dev-ruby/imagesize/imagesize-0.1.1_p20100902.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+RUBY_FAKEGEM_VERSION="0.1.1.20100902"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Measure image size (GIF, PNG, JPEG, etc)"
+HOMEPAGE="http://imagesize.rubyforge.org/"
+COMMIT_ID="bd5be2afb088beba3f0d863cef4eac7db56ca804"
+SRC_URI="https://github.com/mattheworiordan/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RUBY_S="${PN}-${COMMIT_ID}"
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S test/test_image_size.rb || die
+}
diff --git a/dev-ruby/imagesize/metadata.xml b/dev-ruby/imagesize/metadata.xml
new file mode 100644
index 000000000000..81d46ef55ae8
--- /dev/null
+++ b/dev-ruby/imagesize/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">mattheworiordan/imagesize</remote-id>
+ </upstream>
+</pkgmetadata>