summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-09-07 09:09:31 +0200
committerHans de Graaff <graaff@gentoo.org>2024-09-07 10:29:39 +0200
commit2621bbb9f0d1aa30a2287ddce2f55ce7eaff3048 (patch)
tree73e0b7e1c08c7aedbc9ebd4bf8335c50c0650fd1 /dev-ruby/pg
parentdev-util/jenkins-bin: add 2.462.2 (diff)
downloadgentoo-2621bbb9f0d1aa30a2287ddce2f55ce7eaff3048.tar.gz
gentoo-2621bbb9f0d1aa30a2287ddce2f55ce7eaff3048.tar.bz2
gentoo-2621bbb9f0d1aa30a2287ddce2f55ce7eaff3048.zip
dev-ruby/pg: add 1.5.8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/Manifest1
-rw-r--r--dev-ruby/pg/pg-1.5.8.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-ruby/pg/Manifest b/dev-ruby/pg/Manifest
index 54c6c2161b4b..0bc5e13e8dd9 100644
--- a/dev-ruby/pg/Manifest
+++ b/dev-ruby/pg/Manifest
@@ -3,3 +3,4 @@ DIST pg-1.5.4.tar.gz 298368 BLAKE2B 1028fac00371f9f769ee6c484a518149dc7c89e78ee8
DIST pg-1.5.5.tar.gz 299336 BLAKE2B 40410091a24929ee79c14cae8ec6e526a8db569f3f0d5c0637389a099caf8085189bec3fee69c52a07097e1aec62d8da0ee87cdc11118be5c7daefebd9e0019e SHA512 4cd12f2b30d9f853f9707d3329eda0999a7ed0f5ebdbbcb3110996db6d80ef6bb4331b3f6648b19f6fd3f63d928552b58190b34808ca714cbd72c54aeed43478
DIST pg-1.5.6.tar.gz 300559 BLAKE2B 5430789943f107e18f9b509ab7963d6a5dc702782c30a218f5e648397ccc9f07128bae1beccf47172860fe97ae935308841876f26dad0d9ac223adb96722a302 SHA512 5c4cda39699f17864b3dc4daed4ab2096d64245fc2262b948a94c3269b0572a9fab2a42dcba692daf6eeba3354d6a0b05eb5db0f0ca5382b0f8315c1837a0206
DIST pg-1.5.7.tar.gz 302055 BLAKE2B 2d8fbf2f60ee5c2e14a8ab0b649c5f8305fa34423923316f2e05252f31cc98b9f248586c3ad4b4c5d8d0765d1ab96b46e847a42a2d2bebaac68c318435e3d940 SHA512 6546d53e7264bb235c4f6de4b3b3a811f55ca072055dba1f2ab2c783c33f60d137c4f1f40b17711e2805c6c91bdeea90e9774ff56856bc2070ae1d98adb033fc
+DIST pg-1.5.8.tar.gz 303150 BLAKE2B 4fe9abe9441366440ac1b0d481311507e9dea80c882102bcc3a5c564b8007618693944b4be21a5c0a730ca6697b7ffcf33487caa7872c75947ca87c6ad87beaa SHA512 668071787fa89cbd453ca3b65dbd28a166b23d59a25a64f9cc2143909ff870c9ef749238fc81fb38fda757330f19ec24db4a0aae2fad5e93bc38b68f816f2baa
diff --git a/dev-ruby/pg/pg-1.5.8.ebuild b/dev-ruby/pg/pg-1.5.8.ebuild
new file mode 100644
index 000000000000..d9f63c712110
--- /dev/null
+++ b/dev-ruby/pg/pg-1.5.8.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_GEMSPEC="pg.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="Contributors.rdoc README.md History.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="https://github.com/ged/ruby-pg"
+SRC_URI="https://github.com/ged/ruby-pg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-${P}"
+
+LICENSE="|| ( BSD-2 Ruby-BSD )"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+RDEPEND="dev-db/postgresql:*"
+DEPEND="dev-db/postgresql
+ test? ( >=dev-db/postgresql-9.4[server(+),threads(+)] )"
+
+all_ruby_prepare() {
+ # hack the Rakefile to make it sure that it doesn't load
+ # rake-compiler (so that we don't have to depend on it and it
+ # actually works when building with USE=doc).
+ sed -i \
+ -e '/Rakefile.cross/s:^:#:' \
+ -e '/ExtensionTask/,/^end$/ s:^:#:' \
+ Rakefile || die
+
+ sed -e 's/git ls-files -z/find * -print0/' \
+ -e "s:_relative ': './:" \
+ -e 's/__dir__/"."/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Don't allow sudo calls that try to tinker with /etc/hosts (bug #933234)
+ sed -e '/sudo/ s:^:#:' -i spec/helpers.rb || die
+ sed -e '/refreshes DNS address while conn.reset/ s/it/xit/' \
+ -i spec/pg/connection_spec.rb || die
+ sed -e '/doesn.t duplicate hosts in conn.reset/ s/it/xit/' \
+ -i spec/pg/connection_async_spec.rb || die
+
+ # Avoid tests that assume IPv4
+ sed -i -e '/expect.*hostaddr/ s:^:#:' spec/pg/connection_spec.rb || die
+
+ # Fails with network-sandbox
+ sed -i -e '/connects using without host but envirinment variables/askip "gentoo"' spec/pg/scheduler_spec.rb || die
+
+ # Avoid test that only works with bundled pg
+ sed -i -e '/tells about the libpq library path/askip "gentoo"' spec/pg_spec.rb || die
+}
+
+each_ruby_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ RSPEC_VERSION=3 ruby-ng_rspec
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+}