summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ritex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ritex')
-rw-r--r--dev-ruby/ritex/Manifest1
-rw-r--r--dev-ruby/ritex/metadata.xml5
-rw-r--r--dev-ruby/ritex/ritex-1.0.1.ebuild32
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/ritex/Manifest b/dev-ruby/ritex/Manifest
new file mode 100644
index 000000000000..16796ac09696
--- /dev/null
+++ b/dev-ruby/ritex/Manifest
@@ -0,0 +1 @@
+DIST ritex-1.0.1.gem 27136 SHA256 6a307e2dfa238dc8a32b6865ae0f3739200ec35046f7ac83ff5da7efeda8341f SHA512 dd3d13f1fabd6b7c218642b703e2426385ae14a5a5dabfa1d78ff163df0bdfeb38e9a68dd7ba2b1bdb68b122f7b5631c399f23a13fde5aac56159349c2f1de4e WHIRLPOOL 2d12cb614c90de64ec48857fa0239071e35add41802b16f13ff78d8d47810286510db9e2464bff3cea5b79de34a80ae375a82aa32e2abf81030274e7552bcf3a
diff --git a/dev-ruby/ritex/metadata.xml b/dev-ruby/ritex/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/ritex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/ritex/ritex-1.0.1.ebuild b/dev-ruby/ritex/ritex-1.0.1.ebuild
new file mode 100644
index 000000000000..6956fe163833
--- /dev/null
+++ b/dev-ruby/ritex/ritex-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README ReleaseNotes"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Converts expressions from WebTeX into MathML"
+HOMEPAGE="http://masanjin.net/ritex/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/racc"
+DEPEND+=" test? ( app-text/itex2mml )"
+
+all_ruby_prepare() {
+ # Fix tests
+ sed -i -e "s#\./itex2MML#/usr/bin/itex2MML#;142d" test/mathml.rb || die
+ sed -i -e "12d" test/answer-key.yaml || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. test/all.rb || die
+}