summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-12 08:46:00 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-12 09:21:26 +0200
commit9091cc368d674a4a491b1253955eb602e30880d6 (patch)
treec51ec0fc1dc2556aa48a7ef40b3ed2d5b8ffce31 /dev-ruby/rss
parentdev-ruby/nokogiri: drop 1.14.3-r1, 1.15.1, 1.15.2 (diff)
downloadgentoo-9091cc368d674a4a491b1253955eb602e30880d6.tar.gz
gentoo-9091cc368d674a4a491b1253955eb602e30880d6.tar.bz2
gentoo-9091cc368d674a4a491b1253955eb602e30880d6.zip
dev-ruby/rss: add 0.3.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rss')
-rw-r--r--dev-ruby/rss/Manifest1
-rw-r--r--dev-ruby/rss/rss-0.3.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/rss/Manifest b/dev-ruby/rss/Manifest
index 6cf3533dc7f5..000035828af2 100644
--- a/dev-ruby/rss/Manifest
+++ b/dev-ruby/rss/Manifest
@@ -1 +1,2 @@
DIST rss-0.2.9.gem 106496 BLAKE2B 4b8b4b8fc59f05b7ed513294a809b0961dcd0c8b94cbfff3cbb09102a9ad056063c4b2a5d00b30e2eebc76701b10c3b28125ba2daf49fb420c5ff37a47dd600b SHA512 24d983ae2ee8570c3e433675f9cdacd1c35d6160beb28689a0f8cf446b6b465147bef68dab644a85cb089870d6a9fb2df85cbaed12ed4d6a6fb2d07b12c6ca3f
+DIST rss-0.3.0.tar.gz 107114 BLAKE2B a66d1b317e3dd9016f6cb4942e1daed215622b54c50bc5a318d16c145ec20ca7c0bdf330d173ff5484aa529c293fb4391896fda8127ce00cd865fddc17918e30 SHA512 86b7097e3dcf0da03284b44493be43e972a1facb2f20e81cc3303ea0c39336a364858f3d37e04a2397851ca897bd484284eb81cd6d6b55f4c0d77d811350688e
diff --git a/dev-ruby/rss/rss-0.3.0.ebuild b/dev-ruby/rss/rss-0.3.0.ebuild
new file mode 100644
index 000000000000..0e4f35a02554
--- /dev/null
+++ b/dev-ruby/rss/rss-0.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+RUBY_FAKEGEM_GEMSPEC="rss.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Family of libraries that support various formats of XML feeds"
+HOMEPAGE="https://github.com/ruby/rss"
+SRC_URI="https://github.com/ruby/rss/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="0"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/rexml"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/^helper.install/ s:^:#:' Rakefile || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}