summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-10-02 11:07:10 +0200
committerHans de Graaff <graaff@gentoo.org>2016-10-02 19:56:06 +0200
commitc5e7c52e8f9d5a964dbed31a0e005519190645a6 (patch)
treea383a8f0dbe5a332a0ff50c31feaad4b54cae1dd /dev-ruby/ruby-ldap/ruby-ldap-0.9.16-r1.ebuild
parentdev-ruby/ruby-opengl: cleanup (diff)
downloadgentoo-c5e7c52e8f9d5a964dbed31a0e005519190645a6.tar.gz
gentoo-c5e7c52e8f9d5a964dbed31a0e005519190645a6.tar.bz2
gentoo-c5e7c52e8f9d5a964dbed31a0e005519190645a6.zip
dev-ruby/ruby-ldap: cleanup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/ruby-ldap/ruby-ldap-0.9.16-r1.ebuild')
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.16-r1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.16-r1.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.16-r1.ebuild
deleted file mode 100644
index 46ac6f51e87f..000000000000
--- a/dev-ruby/ruby-ldap/ruby-ldap-0.9.16-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-# jruby: mkmf
-# rbx: require 'ldap' no such file to load
-USE_RUBY="ruby20"
-
-inherit multilib ruby-fakegem
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
-
-DESCRIPTION="A Ruby interface to some LDAP libraries"
-HOMEPAGE="http://ruby-ldap.sourceforge.net/"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ~ppc64 sparc x86 ~x86-macos"
-IUSE="ssl"
-DEPEND=">=net-nds/openldap-2
- dev-libs/cyrus-sasl
- ssl? ( dev-libs/openssl:0 )"
-RDEPEND="${DEPEND}"
-
-# Current test set is interactive due to certificate generation and requires
-# running LDAP daemon
-RESTRICT="test"
-
-each_ruby_configure() {
- local myconf="--with-openldap2"
- if ! use ssl ; then
- myconf="${myconf} --without-libcrypto --without-libssl"
- fi
- ${RUBY} extconf.rb ${myconf} || die "extconf.rb failed"
- sed -i -e 's:-Wl,--no-undefined::' \
- -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" Makefile || die
-}
-
-each_ruby_compile() {
- emake V=1
- cp ldap$(get_modname) lib/ || die
-}