summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/itcl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/itcl')
-rw-r--r--dev-tcltk/itcl/Manifest2
-rw-r--r--dev-tcltk/itcl/files/3.4_beta1-test.patch16
-rw-r--r--dev-tcltk/itcl/itcl-3.4.1.ebuild45
-rw-r--r--dev-tcltk/itcl/itcl-4.0.3.ebuild66
-rw-r--r--dev-tcltk/itcl/metadata.xml8
5 files changed, 137 insertions, 0 deletions
diff --git a/dev-tcltk/itcl/Manifest b/dev-tcltk/itcl/Manifest
new file mode 100644
index 000000000000..3bf56d4f7861
--- /dev/null
+++ b/dev-tcltk/itcl/Manifest
@@ -0,0 +1,2 @@
+DIST itcl3.4.1.tar.gz 263316 SHA256 5330832ce72da97610497a58eca904287d0ff91f9ec741a4e4810d5b933c8568 SHA512 288c9b636f1814371bedd33d570a8d46055e136953685a111b76f3b89a6c7aaa1ee9223ceaae1c5ce43198195cb1adc2b178d7c4101d7fd14cb7e756c98bf2b0 WHIRLPOOL c513678bfef5f76b875af68d0bf97fd86b9a9673bb87efbb295dc3faa9a8b011c4c34ed6eddbf648f11b804656e6c99103e8f0ea2c06abc5b1c308b1a5df78cc
+DIST itcl4.0.3.tar.gz 430522 SHA256 bc763f8c666e7f8d59b960816be9e7aa26cbb58531934280ae4f4e5407b4a612 SHA512 9736a08f0f33e0afa677a77eb643454908531786435b73314a80d9ee211c06f037eb0de3c2c2608b728253f9ec613a601d76f16f29964eb06b667ecbb3400df4 WHIRLPOOL c8a971303099139b73d7e72a45e66866811c66b0fa575b57c9ef1600aa02cd322f9d5c685ef285b1cbd03c064665f4504ebd2e549043ede6aecda51d8b88ee91
diff --git a/dev-tcltk/itcl/files/3.4_beta1-test.patch b/dev-tcltk/itcl/files/3.4_beta1-test.patch
new file mode 100644
index 000000000000..16e7fce59c67
--- /dev/null
+++ b/dev-tcltk/itcl/files/3.4_beta1-test.patch
@@ -0,0 +1,16 @@
+ itcl/tests/ensemble.test | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/itcl/tests/ensemble.test b/itcl/tests/ensemble.test
+index c21531e..c36ad5f 100644
+--- a/itcl/tests/ensemble.test
++++ b/itcl/tests/ensemble.test
+@@ -98,7 +98,7 @@ test ensemble-1.10 {part errors are handled gracefully} {
+
+ test ensemble-1.11 {part argument errors are handled gracefully} {
+ list [catch "itcl::ensemble test_numbers {part foo {{}} {}}" msg] $msg $errorInfo
+-} {1 {procedure "foo" has argument with no name} {procedure "foo" has argument with no name
++} {1 {argument with no name} {argument with no name
+ while executing
+ "part foo {{}} {}"
+ ("ensemble" body line 1)
diff --git a/dev-tcltk/itcl/itcl-3.4.1.ebuild b/dev-tcltk/itcl/itcl-3.4.1.ebuild
new file mode 100644
index 000000000000..b893304da932
--- /dev/null
+++ b/dev-tcltk/itcl/itcl-3.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib versionator
+
+MY_P="${PN}${PV/_beta/b}"
+
+DESCRIPTION="Object Oriented Enhancements for Tcl/Tk"
+HOMEPAGE="http://incrtcl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/incrtcl/%5BIncr%20Tcl_Tk%5D-source/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND="<dev-lang/tcl-8.6:0="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}${PV}"
+
+src_compile() {
+ # adjust install_name on darwin
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -i \
+ -e 's:^\(SHLIB_LD\W.*\)$:\1 -install_name ${pkglibdir}/$@:' \
+ "${S}"/Makefile || die 'sed failed'
+ fi
+
+ sed 's:-pipe::g' -i Makefile || die
+
+ emake CFLAGS_DEFAULT="${CFLAGS}"
+}
+
+src_install() {
+ default
+
+ cat >> "${T}"/34${PN} <<- EOF
+ LDPATH="${EPREFIX}/usr/$(get_libdir)/${PN}$(get_version_component_range 1-2)/"
+ EOF
+ doenvd "${T}"/34${PN}
+}
diff --git a/dev-tcltk/itcl/itcl-4.0.3.ebuild b/dev-tcltk/itcl/itcl-4.0.3.ebuild
new file mode 100644
index 000000000000..a7cc698df151
--- /dev/null
+++ b/dev-tcltk/itcl/itcl-4.0.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib versionator
+
+MY_P="${PN}${PV}"
+TCL_VER="8.6.2"
+
+DESCRIPTION="Object Oriented Enhancements for Tcl/Tk"
+HOMEPAGE="http://incrtcl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/incrtcl/%5Bincr%20Tcl_Tk%5D-4-source/itcl%20${PV}/${MY_P}.tar.gz"
+#SRC_URI="mirror://sourceforge/project/incrtcl/%5Bincr%20Tcl_Tk%5D-4-source/itcl%204.0.2/itcl4.0.2.tar.gz"
+#SRC_URI="mirror://sourceforge/project/tcl/Tcl/${TCL_VER}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-lang/tcl-8.6:0="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}${PV}"
+
+# somehow broken
+#RESTRICT=test
+
+src_configure() {
+ econf \
+ --with-tcl="${EPREFIX}"/usr/$(get_libdir) \
+ --with-tclinclude="${EPREFIX}"/usr/include \
+ --disable-rpath
+}
+
+src_compile() {
+ # adjust install_name on darwin
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -i \
+ -e 's:^\(SHLIB_LD\W.*\)$:\1 -install_name ${pkglibdir}/$@:' \
+ "${S}"/Makefile || die 'sed failed'
+ fi
+
+ sed 's:-pipe::g' -i Makefile || die
+
+ emake CFLAGS_DEFAULT="${CFLAGS}"
+}
+
+src_install() {
+ default
+
+ sed \
+ -e "/BUILD_LIB_SPEC/s:-L${S}::g" \
+ -e "/BUILD_STUB_LIB_SPEC/s:-L${S}::g" \
+ -e "/BUILD_STUB_LIB_PATH/s:${S}:${EPREFIX}/usr/$(get_libdir)/${MY_P}/:g" \
+ -e "/INCLUDE_SPEC/s:${S}/generic:${EPREFIX}/usr/include:g" \
+ -e "s:${S}:${EPREFIX}/usr/$(get_libdir)/${MY_P}/:g" \
+ -i "${ED}"/usr/$(get_libdir)/${MY_P}/itclConfig.sh || die
+
+ cat >> "${T}"/34${PN} <<- EOF
+ LDPATH="${EPREFIX}/usr/$(get_libdir)/${PN}$(get_version_component_range 1-3)/"
+ EOF
+ doenvd "${T}"/34${PN}
+}
diff --git a/dev-tcltk/itcl/metadata.xml b/dev-tcltk/itcl/metadata.xml
new file mode 100644
index 000000000000..2f4ceee8b869
--- /dev/null
+++ b/dev-tcltk/itcl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+ <upstream>
+ <remote-id type="sourceforge">incrtcl</remote-id>
+ </upstream>
+</pkgmetadata>