summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-23 13:13:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-23 13:13:20 +0200
commit4a15eeefb3929cfaf628915cb609db3544a7ef04 (patch)
tree69c2ecab1ee455ca02b3f97643d3545d6ed24f6b /dev-tex/latexmk/latexmk-445.ebuild
parentapp-text/epspdf: bump to 0.6.3 (diff)
downloadgentoo-4a15eeefb3929cfaf628915cb609db3544a7ef04.tar.gz
gentoo-4a15eeefb3929cfaf628915cb609db3544a7ef04.tar.bz2
gentoo-4a15eeefb3929cfaf628915cb609db3544a7ef04.zip
dev-tex/latexmk: bump to 445
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-tex/latexmk/latexmk-445.ebuild')
-rw-r--r--dev-tex/latexmk/latexmk-445.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-tex/latexmk/latexmk-445.ebuild b/dev-tex/latexmk/latexmk-445.ebuild
new file mode 100644
index 000000000000..a46fbb239307
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-445.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}