summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-03-01 10:58:37 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-03-01 11:05:32 +0100
commit8119eb4191290ade7f8042e5bb677039b34bbe9e (patch)
treee36cdf885a1b99ea1feae91174e482fdedcfb541 /dev-tex/latexmk
parentdev-tex/biber: add 2.19 (diff)
downloadgentoo-8119eb4191290ade7f8042e5bb677039b34bbe9e.tar.gz
gentoo-8119eb4191290ade7f8042e5bb677039b34bbe9e.tar.bz2
gentoo-8119eb4191290ade7f8042e5bb677039b34bbe9e.zip
dev-tex/latexmk: add 4.83
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-tex/latexmk')
-rw-r--r--dev-tex/latexmk/Manifest1
-rw-r--r--dev-tex/latexmk/latexmk-4.83.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-tex/latexmk/Manifest b/dev-tex/latexmk/Manifest
index 95eaf509dad9..13d03cf622e3 100644
--- a/dev-tex/latexmk/Manifest
+++ b/dev-tex/latexmk/Manifest
@@ -1,2 +1,3 @@
DIST latexmk-470b.zip 458908 BLAKE2B b82f09227412a05fcb662530b2c6691bac72640e5e1bc431de1710ca13b2c97f62f23fbf18a11eff21b222483367c7a4ba88cc197148d8f0b37edc53a96e1490 SHA512 2f984fd9c1785177fd58eb6bad44061bc7b397ed627599557704bae2cef1f53c186d161f99e4aaae5fa33fc66d56936dc9f5b6385f00d85bd634016bac0d555d
DIST latexmk-480.zip 515014 BLAKE2B ec45e6590346c2ab0a226fff08143e5262fd442485c7199b3eea279901753b4d4d7c7d1030e44451a833bbfd74dcf04bae8fd6f63732ac4d5858f5dd96377687 SHA512 38652457a0ba311a7d4e3fdfeec53af27a1f370bf35e4f4214d97946eeece13b67ece22fe5b2c428c3d4d9145f593b683a1fc7993c11c601d8c4d87b592428da
+DIST latexmk-483.zip 542683 BLAKE2B c6c45b878d2c78bec5e9a7daf4f8e513466a904349ef254792c94412bc872ba4a76b7da276e1f6588fec76bfcfa90e0465fe5b3f9b2785361d4acee15bf31a77 SHA512 5a856bb8ec37ab582ce35ba01f6c3ad574b73862e6ed67810b166b34344a2d76c3046e4b7442cac81e8cf7ff64bac674f2b4f5b76f0c0cd266271e930ded093e
diff --git a/dev-tex/latexmk/latexmk-4.83.ebuild b/dev-tex/latexmk/latexmk-4.83.ebuild
new file mode 100644
index 000000000000..cd236a4c229f
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-4.83.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="https://personal.psu.edu/~jcc8/software/latexmk/
+ https://ctan.org/pkg/latexmk/"
+SRC_URI="https://www.cantab.net/users/johncollins/${PN}/${P/./}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/latex-base
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}