summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-02-19 20:49:54 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-02-19 20:49:54 +0700
commit765f83ef451a27b168bea63b0c6a1ad57def6668 (patch)
treed501fc6566d900efcbc6dc62ad1eb564f8b28938 /dev-tex/pythontex/pythontex-0.17.ebuild
parentmedia-video/vlc: Drop USE opencv (diff)
downloadgentoo-765f83ef451a27b168bea63b0c6a1ad57def6668.tar.gz
gentoo-765f83ef451a27b168bea63b0c6a1ad57def6668.tar.bz2
gentoo-765f83ef451a27b168bea63b0c6a1ad57def6668.zip
dev-tex/pythontex: bump to 0.17
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-tex/pythontex/pythontex-0.17.ebuild')
-rw-r--r--dev-tex/pythontex/pythontex-0.17.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-tex/pythontex/pythontex-0.17.ebuild b/dev-tex/pythontex/pythontex-0.17.ebuild
new file mode 100644
index 000000000000..267d1e510960
--- /dev/null
+++ b/dev-tex/pythontex/pythontex-0.17.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit latex-package python-r1
+
+DESCRIPTION="Fast Access to Python from within LaTeX"
+HOMEPAGE="https://github.com/gpoore/pythontex"
+SRC_URI="https://github.com/gpoore/pythontex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LPPL-1.3 BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="highlighting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-texlive/texlive-latexextra-2016
+ dev-tex/pgf"
+RDEPEND="${DEPEND}
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ cd ${PN} || die
+ rm ${PN}.sty || die
+ VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
+}
+
+src_install() {
+ dodoc ${PN}/README "${S}"/*rst ${PN}_quickstart/*
+
+ cd ${PN} || die
+
+ installation() {
+ python_domodule {de,}${PN}3.py
+ python_domodule ${PN}_{engines,utils}.py
+ python_doscript {de,}${PN}.py syncpdb.py
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ latex-package_src_doinstall dtx ins sty
+}