summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-23 15:40:21 +0100
committerSam James <sam@gentoo.org>2024-08-23 15:41:06 +0100
commita04d607f74f91f7ea103f3f33199adb14aa0a1e1 (patch)
treebbd52590fe1be30d29d2488f5c9437199177ee83 /dev-util/bpftool
parentnet-analyzer/netdata: add 1.47.0 (diff)
downloadgentoo-a04d607f74f91f7ea103f3f33199adb14aa0a1e1.tar.gz
gentoo-a04d607f74f91f7ea103f3f33199adb14aa0a1e1.tar.bz2
gentoo-a04d607f74f91f7ea103f3f33199adb14aa0a1e1.zip
dev-util/bpftool: fix assert placement
Otherwise we're not testing the result from xzcat+filterdiff. While here, add a die to the `test -s` check. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/bpftool')
-rw-r--r--dev-util/bpftool/bpftool-7.5.0-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-util/bpftool/bpftool-7.5.0-r1.ebuild b/dev-util/bpftool/bpftool-7.5.0-r1.ebuild
index 95dece1442f5..0d26d0485038 100644
--- a/dev-util/bpftool/bpftool-7.5.0-r1.ebuild
+++ b/dev-util/bpftool/bpftool-7.5.0-r1.ebuild
@@ -68,9 +68,9 @@ src_unpack() {
eshopts_push -o noglob
ebegin "Filtering partial source patch"
xzcat "${DISTDIR}"/${LINUX_PATCH} | filterdiff -p1 ${paths[@]/#/-i} > ${P}.patch
- test -s ${P}.patch
assert -n "Unpacking to ${P} from ${DISTDIR}/${LINUX_PATCH} failed"
eend $? || die "filterdiff failed"
+ test -s ${P}.patch || die "patch is empty?!"
eshopts_pop
fi