summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-01-22 10:36:31 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-01-22 10:38:09 -0800
commit74463fe08fda87744f73223f485bb20a8d243714 (patch)
treed13c8533499eaad09181143205b9bb4651a530cb /dev-util/chroot-wrapper/chroot-wrapper-0.9.4.ebuild
parentdev-tcltk/tkimg: version bump to 1.4.13 (diff)
downloadgentoo-74463fe08fda87744f73223f485bb20a8d243714.tar.gz
gentoo-74463fe08fda87744f73223f485bb20a8d243714.tar.bz2
gentoo-74463fe08fda87744f73223f485bb20a8d243714.zip
dev-util/chroot-wrapper-0.9.4: Version bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util/chroot-wrapper/chroot-wrapper-0.9.4.ebuild')
-rw-r--r--dev-util/chroot-wrapper/chroot-wrapper-0.9.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/chroot-wrapper/chroot-wrapper-0.9.4.ebuild b/dev-util/chroot-wrapper/chroot-wrapper-0.9.4.ebuild
new file mode 100644
index 000000000000..93d2e87ed951
--- /dev/null
+++ b/dev-util/chroot-wrapper/chroot-wrapper-0.9.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="Wrapper for chroot to set up some bind mounts, namespaces, and control groups"
+HOMEPAGE="https://github.com/chutz/chroot-wrapper"
+SRC_URI="https://github.com/chutz/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ sys-apps/util-linux
+ sys-apps/coreutils
+"
+
+CONFIG_CHECK="
+ ~TMPFS
+ ~IPC_NS
+ ~UTS_NS
+"
+
+src_install() {
+ newsbin src/chroot-wrapper chr
+ insinto /etc/chroot-wrapper
+ doins config.bash
+}