summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-09-10 09:08:03 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-09-10 09:08:03 +0200
commit4831a9f5dba2ae669fa5b73054aa403714050e76 (patch)
treeb33616149ec2699b28382a6d37682b79e3d88a09 /dev-util/flawfinder
parentdev-python/ropemode: mark ALLARCHES (diff)
downloadgentoo-4831a9f5dba2ae669fa5b73054aa403714050e76.tar.gz
gentoo-4831a9f5dba2ae669fa5b73054aa403714050e76.tar.bz2
gentoo-4831a9f5dba2ae669fa5b73054aa403714050e76.zip
dev-util/flawfinder: bump 2.0.19
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-util/flawfinder')
-rw-r--r--dev-util/flawfinder/Manifest1
-rw-r--r--dev-util/flawfinder/flawfinder-2.0.19.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/flawfinder/Manifest b/dev-util/flawfinder/Manifest
index 32ed1bbf1ae8..02ffdca4ea98 100644
--- a/dev-util/flawfinder/Manifest
+++ b/dev-util/flawfinder/Manifest
@@ -1,2 +1,3 @@
DIST flawfinder-2.0.15.tar.gz 253677 BLAKE2B 5c4a0e21e0a7f144382c6ca25f713aef9bdb413d4bb5a73f66632ef365f55c75e755ab59cf92fb54dc2d043c8b88be8c28d5f5fca36df6795dabc00313b839f2 SHA512 12b637bae789ee86710c7d6ee203b811e78414ad5d173730bfffe3ea783a76ce999878c57ddaa8019744cac6bf94967663fd9fd80769d7a24b0a79d23c0b0d9d
DIST flawfinder-2.0.18.tar.gz 259960 BLAKE2B 8ddc04d7cef5946d574db499c9d3bd61f9bf8c556d58d649b50544d8c70e76c7dab15391464f5dac3dc229602a6988ddbfaa194dab579cc1b56112af519d6102 SHA512 630be03190f1a8900c001143a9cbb98d2bbd4cc1134097070b39b34a51ff8ee98ff060f082dd7fb5c6773ce1e751926a1b95faac6c307facdba445d919547940
+DIST flawfinder-2.0.19.tar.gz 260817 BLAKE2B d9b74d1882a363fa37aabd4ea6c53a5c18e15d27ee755ce2a2ea7421cb052505ef45290b5dfe7df0c3f92de1f561d274624986291d297dad8d8bf0b3550d5cdd SHA512 7ac8684f157f30cb7cc0e2d9c270f92bb26e9207d9879530c499cc93af10070c2558f3794cc8b1a0a51b52ae771a4aa47157b467d0e6578cab96360cb0c6d90b
diff --git a/dev-util/flawfinder/flawfinder-2.0.19.ebuild b/dev-util/flawfinder/flawfinder-2.0.19.ebuild
new file mode 100644
index 000000000000..a188bbd52941
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-2.0.19.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="https://www.dwheeler.com/flawfinder/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.18-setup.patch )
+
+src_prepare() {
+ sed -e "s/${PN}.1.gz/${PN}.1/g" -i setup.py || die 'sed failed'
+ default
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ local DOCS=( announcement ChangeLog README.md ${PN}.pdf )
+ distutils-r1_python_install_all
+}