summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-07-25 17:51:12 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-07-25 17:52:45 -0500
commit73c09e6e2594611a29572ef82fd71848ebd95b7f (patch)
tree129ca9b45cc9bd99ad36c5b1e4cf297f85263d01 /dev-util/gitlab-runner
parentdev-cpp/benchmark: add 1.7.0 (diff)
downloadgentoo-73c09e6e2594611a29572ef82fd71848ebd95b7f.tar.gz
gentoo-73c09e6e2594611a29572ef82fd71848ebd95b7f.tar.bz2
gentoo-73c09e6e2594611a29572ef82fd71848ebd95b7f.zip
dev-util/gitlab-runner: add 15.1.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.1.1.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 17b382052596..146be42f1d05 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-15.0.0-deps.tar.xz 142912160 BLAKE2B e38db204edb80c76524f58aa
DIST gitlab-runner-15.0.0.tar.gz 1273838 BLAKE2B ac80f8bdd4a750f86d34e98cefad9d3c4e345d9607669c1205e5fbba28f25a83be27c43850383fd81e8222426ed31c2738a59c22cd5b6b6e60765295e7437f17 SHA512 8ba54e690fc45c1e22d174b649fbe3cf78707fd5a146c738c73cba045e6ac00499ddedd7a5f905c0c7e4e804a533d3fc718f8f7ac3c9ec5581de4dd9b3599c80
DIST gitlab-runner-15.1.0-deps.tar.xz 140961872 BLAKE2B 711d2d7b75ab287216963a3871bfcd755d4b5478a37bffcbc64dbe32b93b2c08ca94b0048847697ed83031fc160d9e36589734ccda36526e67d5b4ae621a644b SHA512 58d23e8d25a8c033b517c8f21e6a24c3c449eb7365ae074c18bbda6d2030cc053371da8d5899319a767c922c5923a9042629fe191ba714c3553eadaeb2756a2d
DIST gitlab-runner-15.1.0.tar.gz 1287049 BLAKE2B 76b1c5b535e328941741e55e460de158bcf54d8fa76bc70eba1eed63e7e892f126cdec992cf34ad4c0227f0ee5ba33ec06cea8ba4efd47bf36a540869f71b706 SHA512 7892b4ccfa5973f20deda365e337b8f70e159a9387b6823eada4b39a0cabcd078af08c9bc45e629aa432f49c72f71df6b04fc1cecb72bc2e9c9cd018fc04299b
+DIST gitlab-runner-15.1.1-deps.tar.xz 140961196 BLAKE2B b3818572b2b5c01c78290572219c9788b0c61091eb4fd28978c08b5c9e11c14cf7b988b036598e93f543f9cd02bb22d1e2aa60ff905891948216943db5e28907 SHA512 fedc9bc87deed3a8cbaac8aa641d7a7175b535dca74d0bddc1b59b796a952a794bcfb456055ec19fc561cab060be9c5a09df322cf52daef7cb8152acb89e26b9
+DIST gitlab-runner-15.1.1.tar.gz 1287440 BLAKE2B 0648132a2de277865d3899e460d0f444a26d3d827ee6efdf90abd195b243f31e138f57ca968c702089245e92763ab3cbb7e997fb8dc409a373689ed4e75016bc SHA512 538fc769e0aed90ffe4df9e2afe81b3c89f0c3d9ad9d48e52f12cde5df3b36326f054c1ab88c3d532cf573cdcd7a6e1733d3041cff133a665db5c91c4b8ddd0c
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.1.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.1.1.ebuild
new file mode 100644
index 000000000000..39a1d57d7b63
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.1.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=bfccfab3
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+PATCHES=(
+ # https://gitlab.com/gitlab-org/gitlab-runner/-/merge_requests/3498
+ "${FILESDIR}"/build-for-arm64.patch
+ )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}