summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-18 19:49:54 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-18 20:22:49 -0400
commitf30046ca32f03620cf8359e02fc6836a6adb4062 (patch)
tree41884d273cf7286685289b05db2afc23126a7794 /dev-util/glade
parentdev-embedded/libjaylink: Stabilize 0.2.0 x86, #783930 (diff)
downloadgentoo-f30046ca32f03620cf8359e02fc6836a6adb4062.tar.gz
gentoo-f30046ca32f03620cf8359e02fc6836a6adb4062.tar.bz2
gentoo-f30046ca32f03620cf8359e02fc6836a6adb4062.zip
dev-util/glade: Version bump to 3.38.2
Bug: https://bugs.gentoo.org/747451 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/Manifest1
-rw-r--r--dev-util/glade/glade-3.38.2.ebuild81
-rw-r--r--dev-util/glade/metadata.xml1
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-util/glade/Manifest b/dev-util/glade/Manifest
index 530317bebc7f..70ed8247bf88 100644
--- a/dev-util/glade/Manifest
+++ b/dev-util/glade/Manifest
@@ -1 +1,2 @@
DIST glade-3.36.0.tar.xz 4466808 BLAKE2B ebc93c9471225782bcbcbafc4a475638e77ad763d607188d95e8ac77b3de70f76fefe963027bb6b32ae71adeb1daafdb1a2c98363b25030d83f20f767613f68e SHA512 c984613ade26e3fe68a700a48cccadf5ac96eb716a6e90aad36f3de684faeb607d9aaf112d74a048cd33e222a02388ee6583ca915648486f0259cc805e16d243
+DIST glade-3.38.2.tar.xz 2709224 BLAKE2B 2bcd447b90d6e67abc44dd273f0f5d7fc1d6848ef0bd878481f2c10e8846828e63fbf9c9c96e5effe8126b4aec7eb05886606ca1dc5fb94943bc5d1d8d0ef4e2 SHA512 2df8c8363206905663cd3ac9196da44445425a888b64f1b3b3ac6cd41e14c4a82a5d2c299730ef0606c3970a04dd8f245bb5639218794eb67dcbd26fae17565e
diff --git a/dev-util/glade/glade-3.38.2.ebuild b/dev-util/glade/glade-3.38.2.ebuild
new file mode 100644
index 000000000000..cb60f5a08386
--- /dev/null
+++ b/dev-util/glade/glade-3.38.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit gnome2 python-single-r1 meson virtualx
+
+DESCRIPTION="A user interface designer for GTK+ and GNOME"
+HOMEPAGE="https://glade.gnome.org/"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="3.10/13" # subslot = suffix of libgladeui-2.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="gjs gtk-doc +introspection python webkit"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ dev-libs/atk[introspection?]
+ >=dev-libs/glib-2.53.2:2
+ >=dev-libs/libxml2-2.4.0:2
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.22.0:3[introspection?]
+ x11-libs/pango[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ python? (
+ ${PYTHON_DEPS}
+ x11-libs/gtk+:3[introspection]
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.8:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+ webkit? ( >=net-libs/webkit-gtk-2.12.0:4 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxslt
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+RESTRICT="test" # https://gitlab.gnome.org/GNOME/glade/issues/333
+
+PATCHES=(
+ # To avoid file collison with other slots, rename help module.
+ # Prevent the UI from loading glade:3's gladeui devhelp documentation.
+ "${FILESDIR}"/${PN}-3.14.1-doc-version.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dgladeui=true
+ $(meson_feature gjs)
+ $(meson_feature python)
+ $(meson_feature webkit webkit2gtk)
+
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ optfeature_header
+ optfeature "integration API documentation support" dev-util/devhelp
+}
diff --git a/dev-util/glade/metadata.xml b/dev-util/glade/metadata.xml
index 64de49b2607a..387cac0a8085 100644
--- a/dev-util/glade/metadata.xml
+++ b/dev-util/glade/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo GNOME Desktop</name>
</maintainer>
<use>
+ <flag name="gjs">Build catalog support for <pkg>dev-libs/gjs</pkg> widgets.</flag>
<flag name="webkit">Build catalog support for <pkg>net-libs/webkit-gtk</pkg>:4 widgets.</flag>
</use>
</pkgmetadata>