summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-06-01 19:35:12 +0200
committerHanno Böck <hanno@gentoo.org>2020-06-01 19:36:40 +0200
commita4e88d92f1ccfed61a5277ec9b60aebdaf49e185 (patch)
treee7ee24ddb9146cb5e745baba5669176f07fa4cf7 /dev-util/rebar
parentprofiles: drop chromium mask (diff)
downloadgentoo-a4e88d92f1ccfed61a5277ec9b60aebdaf49e185.tar.gz
gentoo-a4e88d92f1ccfed61a5277ec9b60aebdaf49e185.tar.bz2
gentoo-a4e88d92f1ccfed61a5277ec9b60aebdaf49e185.zip
dev-util/rebar: Fix compatibility with erlang 23.
Closes: https://bugs.gentoo.org/724648 Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-2.3.100, Repoman-2.3.22
Diffstat (limited to 'dev-util/rebar')
-rw-r--r--dev-util/rebar/files/rebar-erlang23.diff12
-rw-r--r--dev-util/rebar/rebar-2.6.4-r1.ebuild30
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/rebar/files/rebar-erlang23.diff b/dev-util/rebar/files/rebar-erlang23.diff
new file mode 100644
index 000000000000..da4835a8b28d
--- /dev/null
+++ b/dev-util/rebar/files/rebar-erlang23.diff
@@ -0,0 +1,12 @@
+diff -Naurp a/src/rebar_port_compiler.erl b/src/rebar_port_compiler.erl
+--- a/src/rebar_port_compiler.erl 2016-08-31 16:47:31.000000000 +0200
++++ b/src/rebar_port_compiler.erl 2020-05-23 13:03:22.464682124 +0200
+@@ -673,7 +673,7 @@ default_env() ->
+ "\" "
+ ])},
+ {"ERL_EI_LIBDIR", lists:concat(["\"", erl_interface_dir(lib), "\""])},
+- {"ERL_LDFLAGS" , " -L$ERL_EI_LIBDIR -lerl_interface -lei"},
++ {"ERL_LDFLAGS" , " -L$ERL_EI_LIBDIR -lei"},
+ {"ERLANG_ARCH" , rebar_utils:wordsize()},
+ {"ERLANG_TARGET", rebar_utils:get_arch()},
+
diff --git a/dev-util/rebar/rebar-2.6.4-r1.ebuild b/dev-util/rebar/rebar-2.6.4-r1.ebuild
new file mode 100644
index 000000000000..ea5c7125e53a
--- /dev/null
+++ b/dev-util/rebar/rebar-2.6.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://github.com/rebar/rebar"
+SRC_URI="https://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/erlang:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/rebar-erlang23.diff" )
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}