summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-31 23:49:33 +0000
committerSam James <sam@gentoo.org>2021-04-11 21:00:00 +0000
commit5b663febf4634ea75ef9e7ab433a2e16e9fde975 (patch)
treeba9c35989a75aab8ee459a5a3d86ef270bdd26e0 /eclass/autotools.eclass
parentautotools.eclass: fix EAPI support logic in config_rpath_update (diff)
downloadgentoo-5b663febf4634ea75ef9e7ab433a2e16e9fde975.tar.gz
gentoo-5b663febf4634ea75ef9e7ab433a2e16e9fde975.tar.bz2
gentoo-5b663febf4634ea75ef9e7ab433a2e16e9fde975.zip
autotools.eclass: drop obsolete EAPI 0 compatibility code
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'eclass/autotools.eclass')
-rw-r--r--eclass/autotools.eclass25
1 files changed, 9 insertions, 16 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 4a963d78db58..e01e72e69b6f 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -26,7 +26,7 @@ fi
if [[ -z ${_AUTOTOOLS_ECLASS} ]] ; then
_AUTOTOOLS_ECLASS=1
-case ${EAPI:-0} in
+case ${EAPI} in
5|6)
# Needed for eqawarn
inherit eutils
@@ -84,15 +84,8 @@ if [[ -n ${WANT_AUTOMAKE} ]] ; then
# on it because we run aclocal to process m4 macros. This matches
# the autoreconf tool, so this requirement is correct, bug #401605.
none) ;;
- latest)
- # Use SLOT deps if we can. For EAPI=0, we get pretty close.
- if [[ ${EAPI:-0} != 0 ]] ; then
- _automake_atom="|| ( `printf '>=sys-devel/automake-%s:%s ' ${_LATEST_AUTOMAKE[@]/:/ }` )"
- else
- _automake_atom="|| ( `printf '>=sys-devel/automake-%s ' ${_LATEST_AUTOMAKE[@]/%:*}` )"
- fi
- ;;
- *) _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*" ;;
+ latest) _automake_atom="|| ( `printf '>=sys-devel/automake-%s:%s ' ${_LATEST_AUTOMAKE[@]/:/ }` )" ;;
+ *) _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*";;
esac
export WANT_AUTOMAKE
fi
@@ -138,8 +131,8 @@ RDEPEND=""
# their own DEPEND string.
: ${AUTOTOOLS_AUTO_DEPEND:=yes}
if [[ ${AUTOTOOLS_AUTO_DEPEND} != "no" ]] ; then
- case ${EAPI:-0} in
- 4|5|6) DEPEND=${AUTOTOOLS_DEPEND} ;;
+ case ${EAPI} in
+ 5|6) DEPEND=${AUTOTOOLS_DEPEND} ;;
7) BDEPEND=${AUTOTOOLS_DEPEND} ;;
esac
fi
@@ -383,7 +376,7 @@ eautoconf() {
fi
if [[ ${WANT_AUTOCONF} != "2.1" && -e configure.in ]] ; then
- case ${EAPI:-0} in
+ case ${EAPI} in
5|6|7)
eqawarn "This package has a configure.in file which has long been deprecated. Please"
eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
@@ -474,8 +467,8 @@ eautopoint() {
config_rpath_update() {
local dst src
- case ${EAPI:-0} in
- 4|5|6)
+ case ${EAPI} in
+ 5|6)
src="${EPREFIX}/usr/share/gettext/config.rpath"
;;
*)
@@ -505,7 +498,7 @@ autotools_env_setup() {
for pv in ${_LATEST_AUTOMAKE[@]/#*:} ; do
# Break on first hit to respect _LATEST_AUTOMAKE order.
local hv_args=""
- case ${EAPI:-0} in
+ case ${EAPI} in
5|6)
hv_args="--host-root"
;;