summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-31 20:40:20 +0000
committerSam James <sam@gentoo.org>2022-12-31 20:40:41 +0000
commit3a2f8ddaec09ebc439453016bb669627bf8a6d6d (patch)
tree120923cbd01987c71d35ddea79a32c9dda21c142 /eclass/qmail.eclass
parentdev-cpp/libxmlpp: Drop old versions (diff)
downloadgentoo-3a2f8ddaec09ebc439453016bb669627bf8a6d6d.tar.gz
gentoo-3a2f8ddaec09ebc439453016bb669627bf8a6d6d.tar.bz2
gentoo-3a2f8ddaec09ebc439453016bb669627bf8a6d6d.zip
qmail.eclass: remove remnants of USE=pop3
Fixes: 24dcd3918e1ac751ff9c8d868509ea1fd6390f78 Fixes: bbc98bfdcbeb0d54f0a389eb7c92f1ffd64af7c6 Closes: https://bugs.gentoo.org/889218 Closes: https://bugs.gentoo.org/889216 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'eclass/qmail.eclass')
-rw-r--r--eclass/qmail.eclass20
1 files changed, 1 insertions, 19 deletions
diff --git a/eclass/qmail.eclass b/eclass/qmail.eclass
index 67069087376d..12f7fa8375b0 100644
--- a/eclass/qmail.eclass
+++ b/eclass/qmail.eclass
@@ -156,11 +156,8 @@ qmail_base_install() {
[[ -x ${i} ]] && doexe ${i}
done
- use pop3 && doexe qmail-pop3d
-
exeopts -o 0 -g qmail -m 711
doexe qmail-{clean,getpw,local,pw2u,remote,rspawn,send} splogger
- use pop3 && doexe qmail-popup
exeopts -o 0 -g qmail -m 700
doexe qmail-{lspawn,newmrh,newu,start}
@@ -240,7 +237,7 @@ qmail_tcprules_install() {
insinto "${TCPRULES_DIR}"
doins "${GENQMAIL_S}"/tcprules/Makefile.qmail
doins "${GENQMAIL_S}"/tcprules/tcp.qmail-*
- use ssl && use pop3 || rm -f "${D}${TCPRULES_DIR}"/tcp.qmail-pop3sd
+ rm -f "${D}${TCPRULES_DIR}"/tcp.qmail-pop3sd
}
qmail_supervise_install_one() {
@@ -260,11 +257,6 @@ qmail_supervise_install() {
for i in qmail-{send,smtpd,qmtpd,qmqpd}; do
qmail_supervise_install_one ${i}
done
-
- if use pop3; then
- qmail_supervise_install_one qmail-pop3d
- use ssl && qmail_supervise_install_one qmail-pop3sd
- fi
}
qmail_spp_install() {
@@ -367,16 +359,6 @@ qmail_supervise_config_notice() {
elog "ln -s ${SUPERVISE_DIR}/qmail-send /service/qmail-send"
elog "ln -s ${SUPERVISE_DIR}/qmail-smtpd /service/qmail-smtpd"
elog
- if use pop3; then
- elog "To start the pop3 server as well, create the following link:"
- elog "ln -s ${SUPERVISE_DIR}/qmail-pop3d /service/qmail-pop3d"
- elog
- if use ssl; then
- elog "To start the pop3s server as well, create the following link:"
- elog "ln -s ${SUPERVISE_DIR}/qmail-pop3sd /service/qmail-pop3sd"
- elog
- fi
- fi
elog "Additionally, the QMTP and QMQP protocols are supported, "
elog "and can be started as:"
elog "ln -s ${SUPERVISE_DIR}/qmail-qmtpd /service/qmail-qmtpd"