summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-07-05 02:23:23 +0200
committerDavid Seifert <soap@gentoo.org>2020-07-05 02:23:23 +0200
commitba89ac49bbdb87a8b7997b68ddca61af0bd7405a (patch)
tree50eadcabb6eafdf604bfd38680198cf26b41703c /games-arcade
parentgames-arcade/insaneodyssey: Re-bootstrap autotools (diff)
downloadgentoo-ba89ac49bbdb87a8b7997b68ddca61af0bd7405a.tar.gz
gentoo-ba89ac49bbdb87a8b7997b68ddca61af0bd7405a.tar.bz2
gentoo-ba89ac49bbdb87a8b7997b68ddca61af0bd7405a.zip
games-arcade/lbreakout2: Call AM_PROG_AR
Closes: https://bugs.gentoo.org/724408 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/lbreakout2/files/lbreakout2-2.6.5-gentoo.patch64
-rw-r--r--games-arcade/lbreakout2/lbreakout2-2.6.5-r1.ebuild36
2 files changed, 55 insertions, 45 deletions
diff --git a/games-arcade/lbreakout2/files/lbreakout2-2.6.5-gentoo.patch b/games-arcade/lbreakout2/files/lbreakout2-2.6.5-gentoo.patch
index 365274c581b9..3284426749af 100644
--- a/games-arcade/lbreakout2/files/lbreakout2-2.6.5-gentoo.patch
+++ b/games-arcade/lbreakout2/files/lbreakout2-2.6.5-gentoo.patch
@@ -1,34 +1,24 @@
---- lbreakout2-2.6.1.orig/Makefile.am
-+++ lbreakout2-2.6.1/Makefile.am
-@@ -1,13 +1,8 @@
- SUBDIRS = intl m4 po common gui game server client docs
-
- EXTRA_DIST = config.rpath AUTHORS COPYING ChangeLog INSTALL README \
--README-SDL.txt TODO lbreakout2.spec touchall lbreakout32.gif \
--lbreakout48.gif lbreakout2.desktop.in win32_mancomp win32_preparchive
--
--desktopdir = $(datadir)/applications
--desktop_DATA = lbreakout2.desktop
--icondir = $(datadir)/icons
--icon_DATA = lbreakout48.gif
-+README-SDL.txt TODO lbreakout2.spec touchall \
-+win32_mancomp win32_preparchive
-
- WIN32_TEXT = AUTHORS COPYING ChangeLog INSTALL README README-SDL.txt \
- TODO lbreakout2.spec ABOUT-NLS
---- lbreakout2-2.6.1.orig/common/gettext.h
-+++ lbreakout2-2.6.1/common/gettext.h
+--- a/common/gettext.h
++++ b/common/gettext.h
@@ -24,6 +24,7 @@
/* Get declarations of GNU message catalog functions. */
# include <libintl.h>
+# include <locale.h>
- #else
+ /* We need locale.h too, otherwise setlocale() bails out; cf. #643471 */
+ #if HAVE_LOCALE_H
+--- a/configure.in
++++ b/configure.in
+@@ -12,6 +12,7 @@
+ dnl Checks for programs.
+ AM_GNU_GETTEXT
+ AC_PROG_CC
++AM_PROG_AR
+ AC_PROG_RANLIB
+ AC_EXEEXT
---- lbreakout2-2.6.1.orig/configure.in
-+++ lbreakout2-2.6.1/configure.in
-@@ -80,8 +80,6 @@
+@@ -80,8 +81,6 @@
[ --enable-netdebug Enable net packet debugging.], netdebug_flag="-DNET_DEBUG_MSG" )
AC_SUBST(netdebug_flag)
@@ -37,8 +27,8 @@
locdir_flag="-DLOCALEDIR=\\\"$localedir\\\""
dnl installation&highscore path
---- lbreakout2-2.6.1.orig/docs/Makefile.am
-+++ lbreakout2-2.6.1/docs/Makefile.am
+--- a/docs/Makefile.am
++++ b/docs/Makefile.am
@@ -7,11 +7,11 @@
warp.jpg screen.jpg
@@ -54,8 +44,26 @@
win32-install-script:
@for file in $(EXTRA_DIST); do \
---- lbreakout2-2.6.1.orig/po/Makefile.in.in
-+++ lbreakout2-2.6.1/po/Makefile.in.in
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,13 +1,8 @@
+ SUBDIRS = intl m4 po common gui game server client docs
+
+ EXTRA_DIST = config.rpath AUTHORS COPYING ChangeLog INSTALL README \
+-README-SDL.txt TODO lbreakout2.spec touchall lbreakout32.gif \
+-lbreakout48.gif lbreakout2.desktop.in win32_mancomp win32_preparchive
+-
+-desktopdir = $(datadir)/applications
+-desktop_DATA = lbreakout2.desktop
+-icondir = $(datadir)/icons
+-icon_DATA = lbreakout48.gif
++README-SDL.txt TODO lbreakout2.spec touchall \
++win32_mancomp win32_preparchive
+
+ WIN32_TEXT = AUTHORS COPYING ChangeLog INSTALL README README-SDL.txt \
+ TODO lbreakout2.spec ABOUT-NLS
+--- a/po/Makefile.in.in
++++ b/po/Makefile.in.in
@@ -24,7 +24,7 @@
exec_prefix = @exec_prefix@
datadir = @datadir@
diff --git a/games-arcade/lbreakout2/lbreakout2-2.6.5-r1.ebuild b/games-arcade/lbreakout2/lbreakout2-2.6.5-r1.ebuild
index 5be797a596df..129ed748d93f 100644
--- a/games-arcade/lbreakout2/lbreakout2-2.6.5-r1.ebuild
+++ b/games-arcade/lbreakout2/lbreakout2-2.6.5-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit autotools desktop flag-o-matic gnome2-utils
levels_V=20141220
@@ -24,36 +25,38 @@ RDEPEND="
media-libs/libsdl[sound,joystick,video]
media-libs/sdl-net
media-libs/sdl-mixer
- nls? ( virtual/libintl )
-"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
-"
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_unpack() {
unpack ${P}.tar.gz
- cd "${S}/client/levels"
+ cd "${S}/client/levels" || die
unpack ${PN}-levelsets-${levels_V}.tar.gz
- if use themes ; then
- mkdir "${WORKDIR}/themes"
- cd "${WORKDIR}/themes"
+ if use themes; then
+ mkdir "${WORKDIR}"/themes || die
+ cd "${WORKDIR}"/themes || die
unpack ${PN}-themes-${themes_V}.tar.gz
# Delete a few duplicate themes (already shipped with lbreakout2
# tarball). Some of them have different case than built-in themes, so it
# is harder to just compare if the filename is the same.
- rm -f absoluteB.zip oz.zip moiree.zip
+ rm -f absoluteB.zip oz.zip moiree.zip || die
+ local f
for f in *.zip; do
- unzip -q "$f" && rm -f "$f" || die
+ unzip -q "${f}" || die
+ rm -f "${f}" || die
done
fi
}
src_prepare() {
default
- eapply "${FILESDIR}"/${P}-gentoo.patch
+ mv configure.{in,ac} || die
eautoreconf
}
@@ -61,17 +64,16 @@ src_configure() {
filter-flags -O?
econf \
--enable-sdl-net \
- --localedir=/usr/share/locale \
- --with-docdir="/usr/share/doc/${PF}/html" \
+ --with-docdir="${EPREFIX}/usr/share/doc/${PF}/html" \
$(use_enable nls)
}
src_install() {
default
- if use themes ; then
+ if use themes; then
insinto /usr/share/lbreakout2/gfx
- doins -r "${WORKDIR}/themes/"*
+ doins -r "${WORKDIR}"/themes/.
fi
newicon client/gfx/win_icon.png ${PN}.png