summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-08 10:42:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-08 11:54:18 +0200
commit5dfbd7110e7333f57a7b839df4c1c51ac261ad25 (patch)
treeaa3b8f4fb6faa049f0474d2a9dc1e67fd5fa78bc /games-emulation/dolphin
parentgames-emulation/dolphin: Remove use of plocale.eclass (diff)
downloadgentoo-5dfbd7110e7333f57a7b839df4c1c51ac261ad25.tar.gz
gentoo-5dfbd7110e7333f57a7b839df4c1c51ac261ad25.tar.bz2
gentoo-5dfbd7110e7333f57a7b839df4c1c51ac261ad25.zip
games-emulation/dolphin: Add missing ||die
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-emulation/dolphin')
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild6
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild b/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
index 8b084ec1f69d..ac9393e5df3d 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
@@ -119,10 +119,12 @@ src_prepare() {
done
# About 50% compile-time speedup
- use vulkan || sed -i -e '/Externals\/glslang/d' CMakeLists.txt
+ if ! use vulkan; then
+ sed -i -e '/Externals\/glslang/d' CMakeLists.txt || die
+ fi
# Remove dirty suffix: needed for netplay
- sed -i -e 's/--dirty/&=""/' CMakeLists.txt
+ sed -i -e 's/--dirty/&=""/' CMakeLists.txt || die
}
src_configure() {
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index c46031141fbd..29779609bc0d 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -121,10 +121,12 @@ src_prepare() {
done
# About 50% compile-time speedup
- use vulkan || sed -i -e '/Externals\/glslang/d' CMakeLists.txt
+ if ! use vulkan; then
+ sed -i -e '/Externals\/glslang/d' CMakeLists.txt || die
+ fi
# Remove dirty suffix: needed for netplay
- sed -i -e 's/--dirty/&=""/' CMakeLists.txt
+ sed -i -e 's/--dirty/&=""/' CMakeLists.txt || die
}
src_configure() {