summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2025-01-26 18:27:37 -0800
committerMichael Orlitzky <mjo@gentoo.org>2025-02-10 02:06:08 +0000
commitc28c55e6f4c3b60c0066b2437593fc56fba921c5 (patch)
tree94e796f301a9f41998f9608250ed1041c092c1d2 /games-emulation/prosystem-jg
parentgames-emulation/mednafen-jg: add missing dependency (diff)
downloadgentoo-c28c55e6f4c3b60c0066b2437593fc56fba921c5.tar.gz
gentoo-c28c55e6f4c3b60c0066b2437593fc56fba921c5.tar.bz2
gentoo-c28c55e6f4c3b60c0066b2437593fc56fba921c5.zip
games-emulation/prosystem-jg: add 1.5.3
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'games-emulation/prosystem-jg')
-rw-r--r--games-emulation/prosystem-jg/Manifest1
-rw-r--r--games-emulation/prosystem-jg/prosystem-jg-1.5.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/games-emulation/prosystem-jg/Manifest b/games-emulation/prosystem-jg/Manifest
index 375afa48650d..2dd3e3d93da3 100644
--- a/games-emulation/prosystem-jg/Manifest
+++ b/games-emulation/prosystem-jg/Manifest
@@ -1 +1,2 @@
DIST prosystem-1.5.2.tar.bz2 49674 BLAKE2B 700924f3d749a551337289a634c3f36801c9a57ac6a68c1940e65f1a6dfb1a8fef0fcf9b3227509656965bcff9e27112b6e847d11593400f22e0cf3706b12b05 SHA512 9e59d0c8e4edaf081e0ba0574a11fd3d24f12375345cbcba483f5d9a4be376fc5dcab3145e9f4deb117ebcdc69ae8da68643c27adfc9b7a42d79903ef7c15d11
+DIST prosystem-1.5.3.tar.bz2 128312 BLAKE2B c410dcdfbd2a2537d5f4cc36e285e3bd39f2c4239eeb6888431bcf85853a9056b03be5e0ae772c3475d544f74715fae48d6bbd0ae56e6b60e0608d8c8fcadf79 SHA512 33a0598a4abe7a07d925d7d6564c85538873643ebb0211c14f83661b702fd6b271f76f3730d555c38b7246a1c6c2ed0dce2cbfe41b4e8efde467c1541ee69585
diff --git a/games-emulation/prosystem-jg/prosystem-jg-1.5.3.ebuild b/games-emulation/prosystem-jg/prosystem-jg-1.5.3.ebuild
new file mode 100644
index 000000000000..e596a5908456
--- /dev/null
+++ b/games-emulation/prosystem-jg/prosystem-jg-1.5.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of ProSystem"
+HOMEPAGE="https://gitlab.com/jgemu/prosystem"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}