summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-31 16:46:13 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-01 13:30:10 +0100
commitf81dbcf454b91dd47c1763ce879ed4208297c90b (patch)
treefb94e883cc8f814b79600743fd9eb2fd286141dd /games-emulation
parentdev-libs/libindicate: update EAPI 6 -> 8 (diff)
downloadgentoo-f81dbcf454b91dd47c1763ce879ed4208297c90b.tar.gz
gentoo-f81dbcf454b91dd47c1763ce879ed4208297c90b.tar.bz2
gentoo-f81dbcf454b91dd47c1763ce879ed4208297c90b.zip
games-emulation/ppsspp: properly pick up python
Closes: https://bugs.gentoo.org/800905 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/ppsspp/ppsspp-1.14-r1.ebuild (renamed from games-emulation/ppsspp/ppsspp-1.14.1.ebuild)9
-rw-r--r--games-emulation/ppsspp/ppsspp-1.14.1-r1.ebuild (renamed from games-emulation/ppsspp/ppsspp-1.14.ebuild)9
2 files changed, 16 insertions, 2 deletions
diff --git a/games-emulation/ppsspp/ppsspp-1.14.1.ebuild b/games-emulation/ppsspp/ppsspp-1.14-r1.ebuild
index 97e3e57bd6db..b8d1f94a03d8 100644
--- a/games-emulation/ppsspp/ppsspp-1.14.1.ebuild
+++ b/games-emulation/ppsspp/ppsspp-1.14-r1.ebuild
@@ -3,7 +3,9 @@
EAPI=8
-inherit xdg cmake
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-any-r1 xdg cmake
DESCRIPTION="A PSP emulator written in C++"
HOMEPAGE="https://www.ppsspp.org/
@@ -37,12 +39,17 @@ RDEPEND="
!qt5? ( media-libs/libsdl2[X,opengl,sound,video] )
"
DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
PATCHES=(
"${FILESDIR}"/${PN}-CMakeLists-flags.patch
"${FILESDIR}"/${PN}-disable-ccache-autodetection.patch
)
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
diff --git a/games-emulation/ppsspp/ppsspp-1.14.ebuild b/games-emulation/ppsspp/ppsspp-1.14.1-r1.ebuild
index 97e3e57bd6db..b8d1f94a03d8 100644
--- a/games-emulation/ppsspp/ppsspp-1.14.ebuild
+++ b/games-emulation/ppsspp/ppsspp-1.14.1-r1.ebuild
@@ -3,7 +3,9 @@
EAPI=8
-inherit xdg cmake
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-any-r1 xdg cmake
DESCRIPTION="A PSP emulator written in C++"
HOMEPAGE="https://www.ppsspp.org/
@@ -37,12 +39,17 @@ RDEPEND="
!qt5? ( media-libs/libsdl2[X,opengl,sound,video] )
"
DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
PATCHES=(
"${FILESDIR}"/${PN}-CMakeLists-flags.patch
"${FILESDIR}"/${PN}-disable-ccache-autodetection.patch
)
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON