summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/avp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/avp')
-rw-r--r--games-fps/avp/Manifest1
-rw-r--r--games-fps/avp/avp-20150214.ebuild51
-rw-r--r--games-fps/avp/metadata.xml5
3 files changed, 57 insertions, 0 deletions
diff --git a/games-fps/avp/Manifest b/games-fps/avp/Manifest
new file mode 100644
index 000000000000..87db9023f095
--- /dev/null
+++ b/games-fps/avp/Manifest
@@ -0,0 +1 @@
+DIST avp-20150214.tar.gz 1718303 SHA256 3cfed951482deae709a7e0743ebba9e3ef27aeec2d68d0588e6361b6368a4a85 SHA512 c485a55ff455498bcf82bc17f2056d35d4c646bdf7809f4c326fc7063a9ce5db9e4893af67dff3f6bedb7d5f96e82f792d7f516044fdbab638113091a5505158 WHIRLPOOL 5fd6ee1d893c0feddab44fd84fb7d3bcd231bd337e28bf2089a2120b367bdc5f22bf9ddad5cb0b911065944266fe7d7efb207e64d34b7ba0090c252e74e8efd3
diff --git a/games-fps/avp/avp-20150214.ebuild b/games-fps/avp/avp-20150214.ebuild
new file mode 100644
index 000000000000..a91dbe9d0929
--- /dev/null
+++ b/games-fps/avp/avp-20150214.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cmake-utils games
+
+DESCRIPTION="Linux port of Aliens vs Predator"
+HOMEPAGE="http://www.icculus.org/avp/"
+SRC_URI="http://www.icculus.org/avp/files/${P}.tar.gz"
+
+LICENSE="AvP"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/openal
+ media-libs/libsdl[video,joystick,opengl]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CMAKE_BUILD_TYPE=Release
+
+src_configure() {
+ local mycmakeargs=(
+ "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
+ -DSDL_TYPE=SDL
+ -DOPENGL_TYPE=OPENGL
+ "-DINSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DINSTALL_DATADIR=${GAMES_DATADIR}/${PN}"
+ "-DINSTALL_BINDIR=${GAMES_BINDIR}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ dogamesbin "${BUILD_DIR}/${PN}"
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Please follow the instructions in /usr/share/doc/${PF}"
+ elog "to install the rest of the game."
+}
diff --git a/games-fps/avp/metadata.xml b/games-fps/avp/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/avp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>