summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/bsod
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/bsod')
-rw-r--r--games-misc/bsod/Manifest1
-rw-r--r--games-misc/bsod/bsod-0.1.ebuild31
-rw-r--r--games-misc/bsod/files/bsod-0.1-Makefile.patch21
-rw-r--r--games-misc/bsod/metadata.xml5
4 files changed, 58 insertions, 0 deletions
diff --git a/games-misc/bsod/Manifest b/games-misc/bsod/Manifest
new file mode 100644
index 000000000000..54f4d3cb16e5
--- /dev/null
+++ b/games-misc/bsod/Manifest
@@ -0,0 +1 @@
+DIST bsod-0.1.tgz 10128 SHA256 ad6eb83637d1eb655ca7891933916266bd0624e08823490083b960ff15531c43 SHA512 2b3087ee495c83f41c2c582dc1c391ce5b73600244b6183abbcd36a3f88caf16987250d4ad23eb3a556b014669ddd84947e6cddeb8d4c89e12c9bacc545299c8 WHIRLPOOL 3317001c0502d50166aac13e252b1f0413f7af71e5cf2cd84c055629421fb9ae153016421b43477e5eb3acba3c9b3243d2a670630b1b6388d46828378e4197e5
diff --git a/games-misc/bsod/bsod-0.1.ebuild b/games-misc/bsod/bsod-0.1.ebuild
new file mode 100644
index 000000000000..52b00dc403f1
--- /dev/null
+++ b/games-misc/bsod/bsod-0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="This program will let you UNIX user experience the authentic microsoft windows experience"
+HOMEPAGE="http://www.vanheusden.com/bsod/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ tc-export PKG_CONFIG
+}
+
+src_install() {
+ dogamesbin ${PN}
+ dodoc Changes
+
+ prepgamesdirs
+}
diff --git a/games-misc/bsod/files/bsod-0.1-Makefile.patch b/games-misc/bsod/files/bsod-0.1-Makefile.patch
new file mode 100644
index 000000000000..b7699c80403b
--- /dev/null
+++ b/games-misc/bsod/files/bsod-0.1-Makefile.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,15 +1,15 @@
+ VERSION=0.1
+
+ DEBUG=-g -pedantic #-pg #-fprofile-arcs
+-LDFLAGS=-lncurses $(DEBUG)
+-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
++LDLIBS=$(shell ${PKG_CONFIG} --libs ncurses)
++CFLAGS+=-Wall -DVERSION=\"$(VERSION)\"
+
+ OBJS=bsod.o
+
+ all: bsod
+
+ bsod: $(OBJS)
+- $(CC) -Wall $(OBJS) $(LDFLAGS) -o bsod
++ $(CC) $(LDFLAGS) $(CFLAGS) $(OBJS) $(LDLIBS) -o bsod
+
+ install: bsod
+ cp bsod $(DESTDIR)/usr/local/bin
diff --git a/games-misc/bsod/metadata.xml b/games-misc/bsod/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-misc/bsod/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>