summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/color-lines
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/color-lines')
-rw-r--r--games-puzzle/color-lines/Manifest1
-rw-r--r--games-puzzle/color-lines/color-lines-0.6.ebuild50
-rw-r--r--games-puzzle/color-lines/files/color-lines-0.6-Makefile.patch35
-rw-r--r--games-puzzle/color-lines/metadata.xml11
4 files changed, 97 insertions, 0 deletions
diff --git a/games-puzzle/color-lines/Manifest b/games-puzzle/color-lines/Manifest
new file mode 100644
index 000000000000..6b9e2c2581ab
--- /dev/null
+++ b/games-puzzle/color-lines/Manifest
@@ -0,0 +1 @@
+DIST lines_0.6.tar.gz 862137 SHA256 e20c87dfcc8f940c8af7784dad12e66fa1cd10d0d97766979fef00eb17c0b0b3 SHA512 fe9e96b598fb6cf0980d0970facbc070715b33491a8f0ad979c57332a22e97ab801e85dd17b5d0b2a1b8aba69b48b6c42dc115b01a36654ad05a5e9a06c5405a WHIRLPOOL aa4e0663433a8a967f7595fcbdac5d11d2ff89c25dd0beeca9541f46a94a005ab1b108240fb5fa511f27c407cdd3511d8cdbc57d287d033221a655fa807e2387
diff --git a/games-puzzle/color-lines/color-lines-0.6.ebuild b/games-puzzle/color-lines/color-lines-0.6.ebuild
new file mode 100644
index 000000000000..7212f1e7de96
--- /dev/null
+++ b/games-puzzle/color-lines/color-lines-0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Color lines game written with SDL with bonus features"
+HOMEPAGE="http://color-lines.googlecode.com/"
+SRC_URI="http://color-lines.googlecode.com/files/lines_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+RDEPEND="media-libs/libsdl[X,sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[wav,mod]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/lines-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+
+ sed -i \
+ -e '/^Encoding/d' \
+ -e '/^Version/d' \
+ -e '/^Icon/s/.png//' \
+ color-lines.desktop.in || die 'sed on color-lines.desktop.in failed'
+
+ epatch_user
+}
+
+src_compile() {
+ emake BINDIR="${EPREFIX}${GAMES_BINDIR}/" GAMEDATADIR="${EPREFIX}${GAMES_DATADIR}/${PN}/"
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r gfx sounds
+
+ domenu ${PN}.desktop
+ doicon icon/${PN}.png
+ dodoc ChangeLog
+ dogamesbin ${PN}
+
+ prepgamesdirs
+}
diff --git a/games-puzzle/color-lines/files/color-lines-0.6-Makefile.patch b/games-puzzle/color-lines/files/color-lines-0.6-Makefile.patch
new file mode 100644
index 000000000000..9f552d712713
--- /dev/null
+++ b/games-puzzle/color-lines/files/color-lines-0.6-Makefile.patch
@@ -0,0 +1,35 @@
+--- Makefile.unix.orig 2013-04-12 13:56:42.131113000 +0400
++++ Makefile.unix 2013-04-12 13:57:26.595946027 +0400
+@@ -2,18 +2,18 @@
+ VERTITLE := lines-$(VERSION)
+ ARCHIVE := lines_$(VERSION).tar.gz
+
+-CFLAGS:=-Wall -O2 $(shell sdl-config --cflags)
++CFLAGS += $(shell sdl-config --cflags)
+ #-DMAEMO
+
+-LDFLAGS:=$(shell sdl-config --libs) -lSDL_image -lSDL_mixer
++LIBS := -lm $(shell sdl-config --libs) -lSDL_image -lSDL_mixer
+
+ SRC := board.c graphics.c main.c sound.c
+ OBJ := $(patsubst %.c, %.o, $(SRC))
+
+ all: color-lines
+-PREFIX:=/usr/local
++PREFIX:=/usr
+
+-BINDIR:=$(DESTDIR)/$(PREFIX)/games/
++BINDIR:=$(DESTDIR)$(PREFIX)/games/bin
+ GAMEDATADIR:=$(DESTDIR)/$(PREFIX)/share/games/color-lines/
+
+ svnclean:
+@@ -29,8 +29,7 @@
+
+ color-lines: $(OBJ)
+ cat color-lines.desktop.in | sed -e "s|@BINDIR|$(BINDIR)|g" > color-lines.desktop
+- $(CC) $(CFLAGS) $(LDFLAGS) $(^) -o $(@)
+- strip color-lines
++ $(CC) $(CFLAGS) $(LDFLAGS) $(^) -o $(@) $(LIBS)
+
+ clean:
+ rm -f *.o color-lines
diff --git a/games-puzzle/color-lines/metadata.xml b/games-puzzle/color-lines/metadata.xml
new file mode 100644
index 000000000000..d2caaa081e19
--- /dev/null
+++ b/games-puzzle/color-lines/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">color-lines</remote-id>
+ </upstream>
+</pkgmetadata>