summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/mures/mures-0.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/mures/mures-0.5.ebuild')
-rw-r--r--games-puzzle/mures/mures-0.5.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/games-puzzle/mures/mures-0.5.ebuild b/games-puzzle/mures/mures-0.5.ebuild
new file mode 100644
index 000000000000..3831ba20ece0
--- /dev/null
+++ b/games-puzzle/mures/mures-0.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit autotools eutils games
+
+DESCRIPTION="A clone of Sega's Chu Chu Rocket"
+HOMEPAGE="http://mures.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mures/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ opengl? ( virtual/opengl )"
+RDEPEND="${DEPEND}"
+
+dir=${GAMES_DATADIR}/${PN}
+
+src_prepare() {
+ # Disable OpenGL support if USE flag is not set
+ if ! use opengl ; then
+ sed -i \
+ -e 's: -DHAVE_GL::' \
+ -e 's: -lGL::' \
+ configure.in || die "sed failed"
+ fi
+
+ sed -i '$ s/\\//' \
+ src/lua/Makefile.am \
+ src/maps/battle/Makefile.am \
+ || die "sed failed"
+
+ epatch "${FILESDIR}"/${P}-underlink.patch
+
+ eautoreconf
+
+ cd src
+
+ # Save to HOME
+ epatch "${FILESDIR}"/${P}-save.patch
+
+ # Modify game data & scrips path
+ sed -i \
+ -e "s:gui/:${dir}/gui/:" \
+ -e "s:sounds/:${dir}/sounds/:" \
+ gui.c || die "sed gui.c failed"
+ sed -i \
+ -e "s:images/:${dir}/images/:" \
+ -e "s:textures/:${dir}/textures/:" \
+ go_sdl.c || die "sed go_sdl.c failed"
+ sed -i \
+ -e "s:textures/:${dir}/textures/:" \
+ go_gl.c || die "sed go_gl.c failed"
+ sed -i \
+ -e "s:input.lua:${dir}/input.lua:" \
+ gi_sdl.c || die "sed gi_sdl.c failed"
+ sed -i \
+ -e "s:images/:${dir}/images/:" \
+ anim.c output.c || die "sed anim.c output.c failed"
+ sed -i \
+ -e "s:maps/:${dir}/maps/:" \
+ load_maps.lua || die "sed load_maps.lua failed"
+ sed -i \
+ -e "s:sounds/:${dir}/sounds/:" \
+ audio_sdl.c || die "sed audio_sdl.c failed"
+ sed -i \
+ -e "s:load_maps.lua:${dir}/load_maps.lua:" \
+ map.c || die "sed map.c failed"
+}
+
+src_install() {
+ # Remove makefiles before installation
+ rm -f src/*/Makefile* src/*/*/Makefile* || die "removing makefiles"
+ insinto "${dir}"
+ doins -r src/{gui,images,sounds,textures,maps,*.lua}
+ dodoc README TODO ChangeLog AUTHORS
+ dogamesbin src/mures
+
+ prepgamesdirs
+}