summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-07-23 03:17:15 -0400
committerMichael Palimaka <kensington@gentoo.org>2017-07-23 22:32:30 +1000
commit971bbd8c85e82b4538338f5a5919d6ee5f4776d1 (patch)
treea69819aaaa89d2cb9dac2ad00158d9662d2bba3f /games-roguelike
parentapp-i18n/canna: set default encoding of canuum to EUC-JP (diff)
downloadgentoo-971bbd8c85e82b4538338f5a5919d6ee5f4776d1.tar.gz
gentoo-971bbd8c85e82b4538338f5a5919d6ee5f4776d1.tar.bz2
gentoo-971bbd8c85e82b4538338f5a5919d6ee5f4776d1.zip
games-roguelike/scourge: Fix building with GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=610492 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-gcc6.patch34
-rw-r--r--games-roguelike/scourge/scourge-0.21.1-r1.ebuild3
2 files changed, 36 insertions, 1 deletions
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-gcc6.patch b/games-roguelike/scourge/files/scourge-0.21.1-gcc6.patch
new file mode 100644
index 000000000000..fed15f45ed7e
--- /dev/null
+++ b/games-roguelike/scourge/files/scourge-0.21.1-gcc6.patch
@@ -0,0 +1,34 @@
+Bug: https://bugs.gentoo.org/610492
+Upstream ticket: https://sourceforge.net/p/scourge/patches/3/
+
+--- a/src/equip.cpp
++++ b/src/equip.cpp
+@@ -595,7 +595,7 @@
+ }
+ }
+ if ( !found ) {
+- specialSkill = false;
++ specialSkill = NULL;
+ canvas->setTooltip( "" );
+ }
+ glDisable( GL_BLEND );
+--- a/src/render/map.cpp
++++ b/src/render/map.cpp
+@@ -3154,7 +3154,7 @@
+ if ( shape )
+ return shape;
+ }
+- return false;
++ return NULL;
+ }
+ if ( y1 == y2 ) {
+ if ( x1 > x2 ) SWAP( x1, x2 );
+@@ -3163,7 +3163,7 @@
+ if ( shape )
+ return shape;
+ }
+- return false;
++ return NULL;
+ }
+
+
diff --git a/games-roguelike/scourge/scourge-0.21.1-r1.ebuild b/games-roguelike/scourge/scourge-0.21.1-r1.ebuild
index db3edafb19a6..6f23afbb4196 100644
--- a/games-roguelike/scourge/scourge-0.21.1-r1.ebuild
+++ b/games-roguelike/scourge/scourge-0.21.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,6 +31,7 @@ S=${WORKDIR}/${PN}
PATCHES=(
"${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-gcc6.patch
"${FILESDIR}"/${P}-automake-1.13.patch
)