summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-15 05:11:46 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-15 05:34:37 -0500
commit0eda81af1a4603f7d5d21b998cc796694a99a1cd (patch)
tree981328717038dfdf3db83b435dffc697f8a976da /games-strategy
parentdev-ruby/elasticsearch-transport: drop 7.17.10 (diff)
downloadgentoo-0eda81af1a4603f7d5d21b998cc796694a99a1cd.tar.gz
gentoo-0eda81af1a4603f7d5d21b998cc796694a99a1cd.tar.bz2
gentoo-0eda81af1a4603f7d5d21b998cc796694a99a1cd.zip
games-strategy/widelands: update live, enable py3.13
Upstream now treats RelWithDebInfo the same as Release, which means it now drops -Werror with the eclass' default. Been a while, but at a glance nothing else needs updating if going by the 1.2.1 release (haven't actually tried 9999). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/widelands/widelands-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/games-strategy/widelands/widelands-9999.ebuild b/games-strategy/widelands/widelands-9999.ebuild
index a573f92451d1..c3f0df651d6b 100644
--- a/games-strategy/widelands/widelands-9999.ebuild
+++ b/games-strategy/widelands/widelands-9999.ebuild
@@ -3,21 +3,24 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit cmake python-any-r1 xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/widelands/widelands.git"
else
- SRC_URI="https://github.com/widelands/widelands/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/widelands/widelands/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ "
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
DESCRIPTION="Game similar to Settlers 2"
HOMEPAGE="https://www.widelands.org/"
-LICENSE="GPL-2+ || ( Apache-2.0 GPL-3 ) BitstreamVera CC-BY-SA-3.0 MIT OFL-1.1"
+LICENSE="GPL-2+ || ( Apache-2.0 GPL-3 ) BitstreamVera BSD CC-BY-SA-3.0 MIT OFL-1.1"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -44,8 +47,6 @@ BDEPEND="
"
src_configure() {
- CMAKE_BUILD_TYPE=Release # disables -Werror
-
local mycmakeargs=(
-DWL_INSTALL_BASEDIR="${EPREFIX}"/usr/share/doc/${PF}
-DWL_INSTALL_BINDIR="${EPREFIX}"/usr/bin