summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-17 01:12:57 +0000
committerSam James <sam@gentoo.org>2021-01-17 01:17:16 +0000
commit58b4677f8fed20a5996c79496f93f992665e385a (patch)
treedd20d57ef50701d9315015d4bd74b6b6aee7ca9c /games-strategy
parentgames-strategy/0ad-data: Version bump (0.0.24_alpha_pre20210116040036). (diff)
downloadgentoo-58b4677f8fed20a5996c79496f93f992665e385a.tar.gz
gentoo-58b4677f8fed20a5996c79496f93f992665e385a.tar.bz2
gentoo-58b4677f8fed20a5996c79496f93f992665e385a.zip
games-strategy/0ad: misc fixups
* Tighten nvtt dep * Use xdg-utils -> xdg Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036.ebuild21
1 files changed, 8 insertions, 13 deletions
diff --git a/games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036.ebuild b/games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036.ebuild
index efaa45777743..aff130d91e0c 100644
--- a/games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036.ebuild
+++ b/games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036.ebuild
@@ -1,10 +1,10 @@
# Copyright 2014-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-WX_GTK_VER="3.0-gtk3"
+EAPI=7
-inherit desktop toolchain-funcs wxwidgets xdg-utils
+WX_GTK_VER="3.0-gtk3"
+inherit desktop toolchain-funcs wxwidgets xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -54,7 +54,8 @@ DEPEND="
x11-libs/libX11
editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
lobby? ( >=net-libs/gloox-1.0.20 )
- nvtt? ( media-gfx/nvidia-texture-tools )"
+ nvtt? ( >=media-gfx/nvidia-texture-tools-2.1.0 )"
+
RDEPEND="${DEPEND}"
PDEPEND="~games-strategy/0ad-data-${PV}"
@@ -94,7 +95,9 @@ src_configure() {
--bindir="/usr/bin"
--libdir="/usr/$(get_libdir)"/${PN}
--datadir="/usr/share/${PN}"
- )
+ )
+
+ tc-export CC CXX
# stock premake5 does not work, use the shipped one
emake -C "${S}"/build/premake/premake5/build/gmake2.unix
@@ -147,11 +150,3 @@ src_install() {
doicon -s 128 build/resources/${PN}.png
make_desktop_entry ${PN}
}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}