summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2025-01-02 22:59:57 +0000
committerJames Le Cuirot <chewi@gentoo.org>2025-01-02 22:59:57 +0000
commit841e2d2510ed3149ecbb05b0210a4362c5096347 (patch)
tree363a3660cdda29345141f882830d0aa156f47b3d /games-util
parentapp-emacs/lean-mode: remove unnecessary lean rdep (diff)
downloadgentoo-841e2d2510ed3149ecbb05b0210a4362c5096347.tar.gz
gentoo-841e2d2510ed3149ecbb05b0210a4362c5096347.tar.bz2
gentoo-841e2d2510ed3149ecbb05b0210a4362c5096347.zip
games-util/lgogdownloader: Unify live and regular ebuilds
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild10
-rw-r--r--games-util/lgogdownloader/lgogdownloader-9999.ebuild11
2 files changed, 17 insertions, 4 deletions
diff --git a/games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild b/games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild
index 384ea18d90ab..447b5479cb96 100644
--- a/games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild
@@ -5,13 +5,19 @@ EAPI=8
inherit cmake
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Sude-/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
DESCRIPTION="Unofficial GOG.com downloader for Linux"
HOMEPAGE="https://sites.google.com/site/gogdownloader/"
-SRC_URI="https://github.com/Sude-/${PN}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="WTFPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
IUSE="gui"
RDEPEND="
diff --git a/games-util/lgogdownloader/lgogdownloader-9999.ebuild b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
index 74f57ee662f9..447b5479cb96 100644
--- a/games-util/lgogdownloader/lgogdownloader-9999.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
@@ -3,11 +3,18 @@
EAPI=8
-inherit cmake git-r3
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Sude-/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="Unofficial GOG.com downloader for Linux"
HOMEPAGE="https://sites.google.com/site/gogdownloader/"
-EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
LICENSE="WTFPL-2"
SLOT="0"