summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-11 15:55:05 -0400
committerSam James <sam@gentoo.org>2024-03-11 21:31:42 +0000
commit29ebff42ad3f27fca5015f1c2e5b1c2f7ae4e0a7 (patch)
treee65ea4d42c6fe823f78b49641a5770136dbff286 /gnome-base/gnome-control-center
parentnet-libs/gnome-online-accounts: backport patch for libxml2 2.12 compat (diff)
downloadgentoo-29ebff42ad3f27fca5015f1c2e5b1c2f7ae4e0a7.tar.gz
gentoo-29ebff42ad3f27fca5015f1c2e5b1c2f7ae4e0a7.tar.bz2
gentoo-29ebff42ad3f27fca5015f1c2e5b1c2f7ae4e0a7.zip
gnome-base/gnome-control-center: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/889008 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-base/gnome-control-center')
-rw-r--r--gnome-base/gnome-control-center/gnome-control-center-45.2.ebuild10
-rw-r--r--gnome-base/gnome-control-center/gnome-control-center-45.3.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/gnome-base/gnome-control-center/gnome-control-center-45.2.ebuild b/gnome-base/gnome-control-center/gnome-control-center-45.2.ebuild
index 1011a8f36d34..4dc180b6f5ed 100644
--- a/gnome-base/gnome-control-center/gnome-control-center-45.2.ebuild
+++ b/gnome-base/gnome-control-center/gnome-control-center-45.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
-inherit gnome.org gnome2-utils meson python-any-r1 virtualx xdg
+inherit flag-o-matic gnome.org gnome2-utils meson python-any-r1 virtualx xdg
DESCRIPTION="GNOME's main interface to configure various aspects of the desktop"
HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-control-center"
@@ -164,6 +164,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/889008
+ # https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/2563
+ #
+ # Do not trust with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local emesonargs=(
$(meson_use bluetooth)
-Dcups=$(usex cups enabled disabled)
diff --git a/gnome-base/gnome-control-center/gnome-control-center-45.3.ebuild b/gnome-base/gnome-control-center/gnome-control-center-45.3.ebuild
index fd6c58d0f306..ef90ee00bdce 100644
--- a/gnome-base/gnome-control-center/gnome-control-center-45.3.ebuild
+++ b/gnome-base/gnome-control-center/gnome-control-center-45.3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit gnome.org gnome2-utils meson python-any-r1 virtualx xdg
+inherit flag-o-matic gnome.org gnome2-utils meson python-any-r1 virtualx xdg
DESCRIPTION="GNOME's main interface to configure various aspects of the desktop"
HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-control-center"
@@ -159,6 +159,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/889008
+ # https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/2563
+ #
+ # Do not trust with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local emesonargs=(
$(meson_use bluetooth)
-Dcups=$(usex cups enabled disabled)