summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-18 09:46:24 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-18 09:50:08 +0200
commit652f112eafe9f29a060a10c67feab82d58079c14 (patch)
treedd9559a5a1e22ff2308792b5ae8dcbac7aa39bd6 /gnome-base
parentgnome-base/gnome-settings-daemon: add missing constraint between wayland and ... (diff)
downloadgentoo-652f112eafe9f29a060a10c67feab82d58079c14.tar.gz
gentoo-652f112eafe9f29a060a10c67feab82d58079c14.tar.bz2
gentoo-652f112eafe9f29a060a10c67feab82d58079c14.zip
gnome-base/gnome-settings-daemon: fix build issue with USE="udev -wayland", bug #627966
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-settings-daemon/files/3.24.3-fix-wayland-build.patch53
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.24.3.ebuild2
2 files changed, 55 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/files/3.24.3-fix-wayland-build.patch b/gnome-base/gnome-settings-daemon/files/3.24.3-fix-wayland-build.patch
new file mode 100644
index 000000000000..4a06889aaa23
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/3.24.3-fix-wayland-build.patch
@@ -0,0 +1,53 @@
+From 58403ad7677d98fbb14b020dc4d15c52a695496e Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Fri, 18 Aug 2017 09:42:56 +0200
+Subject: [PATCH] Fix build issue when gudev is detected in the absence of
+ wayland
+
+See https://bugs.gentoo.org/show_bug.cgi?id=627966
+---
+ configure.ac | 5 +++++
+ plugins/common/Makefile.am | 2 +-
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 908b3a3a..c89d5e2d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -140,15 +140,20 @@ AC_ARG_ENABLE(wayland,
+ AS_HELP_STRING([--disable-wayland],[Disable wayland support (default: auto)]),
+ enable_wayland=$enableval, enable_wayland=auto)
+ if test x$enable_wayland != xno; then
++ AS_IF([test "$have_udev" = no],
++ [AC_MSG_ERROR([udev is required for Wayland support])])
++
+ PKG_CHECK_MODULES(WAYLAND, wayland-client, have_wayland=yes, have_wayland=no)
+ if test x$have_wayland = xyes; then
+ AC_DEFINE(HAVE_WAYLAND, 1, [Define if libwayland-client is available])
++ GUDEV_PKG="$GUDEV_PKG gdk-wayland-3.0"
+ else
+ if test x$enable_wayland = xyes; then
+ AC_MSG_ERROR([Wayland enabled but not found])
+ fi
+ fi
+ fi
++AM_CONDITIONAL(HAVE_WAYLAND, test x$have_wayland = xyes)
+
+ dnl ================================================================
+ dnl Plugins
+diff --git a/plugins/common/Makefile.am b/plugins/common/Makefile.am
+index 107e4d3b..760f3198 100644
+--- a/plugins/common/Makefile.am
++++ b/plugins/common/Makefile.am
+@@ -40,7 +40,7 @@ libcommon_la_SOURCES = \
+ gsd-shell-helper.c \
+ gsd-shell-helper.h
+
+-if HAVE_GUDEV
++if HAVE_WAYLAND
+ libcommon_la_SOURCES += \
+ gsd-device-manager-udev.c \
+ gsd-device-manager-udev.h
+--
+2.14.1
+
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.24.3.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.24.3.ebuild
index 22f909e01a98..3534c5fa68f0 100644
--- a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.24.3.ebuild
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.24.3.ebuild
@@ -108,6 +108,8 @@ PATCHES=(
"${FILESDIR}"/3.24.2-remove-unneeded-gtk-init.patch
# Reduce memory usage by using a fake CSS theme instead of full Adwaita for GTK+ needing plugins; requires eautoreconf
"${FILESDIR}"/3.24.2-reduce-memory-usage.patch
+ # Fix build issue when gudev is present but not wayland, bug #627966
+ "${FILESDIR}"/3.24.3-fix-wayland-build.patch
)
python_check_deps() {