summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/cameramonitor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/cameramonitor')
-rw-r--r--gnome-extra/cameramonitor/Manifest1
-rw-r--r--gnome-extra/cameramonitor/cameramonitor-0.3.2.ebuild51
-rw-r--r--gnome-extra/cameramonitor/metadata.xml17
3 files changed, 69 insertions, 0 deletions
diff --git a/gnome-extra/cameramonitor/Manifest b/gnome-extra/cameramonitor/Manifest
new file mode 100644
index 000000000000..bf92df5afc4d
--- /dev/null
+++ b/gnome-extra/cameramonitor/Manifest
@@ -0,0 +1 @@
+DIST cameramonitor-0.3.2.tar.bz2 216979 SHA256 04b120c8f3eb7f6c02976b0f3de21ecd13005c920e2acb294e3ffcad7fcd2058 SHA512 4e3d66f5829c111d524fe3cef5c9a330ee72e88c6c5dc3bbb528f10e81aa31682ab75a6fe7d4366ec63315341149d0472745917965bec2099590028327c75910 WHIRLPOOL 6ce61889e82aa0ad12f83ff99a8d497af83838fd1e206d7000cf2714793e0ed22ceeccf6b4089580f771db61a218be151640d0d7b46bbf7359d01a7f065cb7c7
diff --git a/gnome-extra/cameramonitor/cameramonitor-0.3.2.ebuild b/gnome-extra/cameramonitor/cameramonitor-0.3.2.ebuild
new file mode 100644
index 000000000000..842ab77edfbf
--- /dev/null
+++ b/gnome-extra/cameramonitor/cameramonitor-0.3.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit gnome2 python autotools
+
+DESCRIPTION="Local Webcam monitoring in system tray"
+HOMEPAGE="https://launchpad.net/cameramonitor"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/gconf-python:2
+ dev-python/notify-python
+ dev-python/pyinotify
+ dev-python/dbus-python"
+
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_clean_py-compile_files
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize cameramonitor
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup cameramonitor
+}
diff --git a/gnome-extra/cameramonitor/metadata.xml b/gnome-extra/cameramonitor/metadata.xml
new file mode 100644
index 000000000000..90ea27a7ce60
--- /dev/null
+++ b/gnome-extra/cameramonitor/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>phobosk@fastmail.fm</email>
+ <name>PhobosK</name>
+ <description>Proxy maintainer. Assign bugs to him.</description>
+ </maintainer>
+ <longdescription>
+Camera Monitor is a little system tray icon that monitors your Webcam activity.
+It is designed for the GNOME desktop, but should work as well on KDE and Xfce.
+</longdescription>
+ <upstream>
+ <remote-id type="launchpad">cameramonitor</remote-id>
+ </upstream>
+</pkgmetadata>