summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-10-26 14:21:32 -0300
committerPacho Ramos <pacho@gentoo.org>2024-11-08 19:16:05 +0100
commit4a53db0c33edbe30512811b5c8f5e20f7664487c (patch)
tree6db9e78083cb75d5a391c75d5487a228a3b428e6 /gnome-extra
parentgnome-extra/gnome-network-displays: drop 0.90.5-r1 (diff)
downloadgentoo-4a53db0c33edbe30512811b5c8f5e20f7664487c.tar.gz
gentoo-4a53db0c33edbe30512811b5c8f5e20f7664487c.tar.bz2
gentoo-4a53db0c33edbe30512811b5c8f5e20f7664487c.zip
gnome-extra/zenity: Bump to 4.0.3
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39118 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/zenity-4.0.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index 219171d06d8d..71d3fb4413d4 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1,2 +1,3 @@
DIST zenity-4.0.1.tar.xz 3093476 BLAKE2B 47ea26adc69bd302e8c59d2fae9c5647fbbadbfd9c61870d6ab5e85cf2bc62af415236cef782ae6f790a756c265113bb23e5be449447270dc0ec41cae23506a5 SHA512 f84e14fd66dbe6bd21d030c1879d8d44250bc8c0661c5ccb6cad7fe8d257e4b01427ce27894cf5a5c27566113587f6b34adc9051826e870e44b836b5c63fb11f
DIST zenity-4.0.2.tar.xz 3095860 BLAKE2B bb72db8ad7ff7d73e7bc515de3c98cf2067763406e6ebfb093fdff14f728710d44dcd7c5f2bb6e066adbd051a508e26758ba052c5ef3efa895aac234f61eaf55 SHA512 2a8ba44d1189ffd3e7630e54418f6ce16d5187b8dc282ea921313413968ff4f20496f569c5dfd403256114ef4f00c33f2500fc08323b46d541493d7ab87bb365
+DIST zenity-4.0.3.tar.xz 3095660 BLAKE2B 16b9c00da77937affb9d60558d14f60b740e66d054450b990ca69fab7117de5407b2f16619ca6eeaa7f542bbb58a3494b5d5326163e8e1c1f00dc7f4534033cc SHA512 1af74fe560cf154ace1309a1c708eb5f4f1e7cde37fd5253855019f93d20dd144b1d3f4c2792a77bf1d2d19f204f49f59bb5407331f6777ab4c0905e94fad059
diff --git a/gnome-extra/zenity/zenity-4.0.3.ebuild b/gnome-extra/zenity/zenity-4.0.3.ebuild
new file mode 100644
index 000000000000..2211ac82943a
--- /dev/null
+++ b/gnome-extra/zenity/zenity-4.0.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/zenity"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="man webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=gui-libs/libadwaita-1.2:1
+ webkit? ( >=net-libs/webkit-gtk-2.40.1:6 )
+ man? ( sys-apps/help2man )
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use webkit webkitgtk)
+ $(meson_use man manpage)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}