summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-29 23:07:22 +0100
committerSam James <sam@gentoo.org>2022-08-29 23:07:22 +0100
commit5890ab330b1fe490a6c938fa974391993da52c8c (patch)
treeb4744e065c672cf60b86c1ad8069569c80a20821 /gui-apps
parentdev-libs/openssl: Stabilize 1.1.1q hppa, #858143 (diff)
downloadgentoo-5890ab330b1fe490a6c938fa974391993da52c8c.tar.gz
gentoo-5890ab330b1fe490a6c938fa974391993da52c8c.tar.bz2
gentoo-5890ab330b1fe490a6c938fa974391993da52c8c.zip
gui-apps/waybar: fix build w/ libc++
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/waybar/files/waybar-0.9.13-libcxx-build.patch36
-rw-r--r--gui-apps/waybar/waybar-0.9.13.ebuild4
2 files changed, 40 insertions, 0 deletions
diff --git a/gui-apps/waybar/files/waybar-0.9.13-libcxx-build.patch b/gui-apps/waybar/files/waybar-0.9.13-libcxx-build.patch
new file mode 100644
index 000000000000..ad24e22fc437
--- /dev/null
+++ b/gui-apps/waybar/files/waybar-0.9.13-libcxx-build.patch
@@ -0,0 +1,36 @@
+https://github.com/Alexays/Waybar/commit/d25278f710a4932798c98141bcf5b482de0e9166
+
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 23 May 2022 16:23:00 +0000
+Subject: [PATCH] fix(upower): add missing include for libc++
+
+In file included from src/modules/upower/upower.cpp:1:
+include/modules/upower/upower.hpp:25:16: error: no template named 'unordered_map' in namespace 'std'
+ typedef std::unordered_map<std::string, UpDevice *> Devices;
+ ~~~~~^
+In file included from src/modules/upower/upower_tooltip.cpp:1:
+include/modules/upower/upower_tooltip.hpp:13:16: error: no template named 'unordered_map' in namespace 'std'
+ typedef std::unordered_map<std::string, UpDevice*> Devices;
+ ~~~~~^
+--- a/include/modules/upower/upower.hpp
++++ b/include/modules/upower/upower.hpp
+@@ -5,6 +5,7 @@
+ #include <iostream>
+ #include <map>
+ #include <string>
++#include <unordered_map>
+
+ #include "ALabel.hpp"
+ #include "glibconfig.h"
+--- a/include/modules/upower/upower_tooltip.hpp
++++ b/include/modules/upower/upower_tooltip.hpp
+@@ -2,6 +2,8 @@
+
+ #include <libupower-glib/upower.h>
+
++#include <unordered_map>
++
+ #include "gtkmm/box.h"
+ #include "gtkmm/label.h"
+ #include "gtkmm/window.h"
+
diff --git a/gui-apps/waybar/waybar-0.9.13.ebuild b/gui-apps/waybar/waybar-0.9.13.ebuild
index 6fbac657f700..c4886a844841 100644
--- a/gui-apps/waybar/waybar-0.9.13.ebuild
+++ b/gui-apps/waybar/waybar-0.9.13.ebuild
@@ -57,6 +57,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-libcxx-build.patch
+)
+
src_configure() {
local emesonargs=(
$(meson_feature mpd)