summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-23 19:14:57 -0700
committerYixun Lan <dlan@gentoo.org>2024-07-25 00:01:02 +0000
commit1937353f68d84b3a0567888b55bd995e3ec6ff27 (patch)
tree56c22580b1231a20284e040b986856ac6ad42a1b /gui-libs/hyprutils
parentdev-util/hyprwayland-scanner: add 0.4.0 (diff)
downloadgentoo-1937353f68d84b3a0567888b55bd995e3ec6ff27.tar.gz
gentoo-1937353f68d84b3a0567888b55bd995e3ec6ff27.tar.bz2
gentoo-1937353f68d84b3a0567888b55bd995e3ec6ff27.zip
gui-libs/hyprutils: add 0.2.0
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-libs/hyprutils')
-rw-r--r--gui-libs/hyprutils/Manifest1
-rw-r--r--gui-libs/hyprutils/hyprutils-0.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/gui-libs/hyprutils/Manifest b/gui-libs/hyprutils/Manifest
index 16b405fa3b95..977241e40464 100644
--- a/gui-libs/hyprutils/Manifest
+++ b/gui-libs/hyprutils/Manifest
@@ -1,2 +1,3 @@
DIST hyprutils-0.1.4.gh.tar.gz 16561 BLAKE2B 90c435f892015791a88870613235204e39e0e41cbeea00a8f21d7f0c84dd2cbe733604da9830334e4f21a0d57d21aa770cc69dc5a34c9324e673d1c86e732606 SHA512 78b1ad188579b7ba9fb32f08aa3da6e96ec18544a1802d144cee9f64f473b6ee41a4cb3fba971524cfbf448e6cbe0aa32c36f53e8d50cbdf926126a9a44da8b6
DIST hyprutils-0.1.5.gh.tar.gz 17974 BLAKE2B 2992cbc27c908c6ec86210fdd89969d77031d1b146b5607bffbf9fa457e24bee2edbdc52c64972ffc56df98799ffd77eba800892b0c126b1340aec7b03d03775 SHA512 c7ca50507871aacdb9054a308d03bfd666df817f1020a6c8df00cd88d3368ffcda629eb5b3952a4fece4b191f8cf739d8f837b3baf59bc8582c310063b60037a
+DIST hyprutils-0.2.0.gh.tar.gz 19268 BLAKE2B 84afffb7f74f9882c4744963e9979c3035d5dbdc7ba914aee17f0a8968a0e218152830414c37cc760c1d43d580d0a04ca272bbaf04260222c757e3dfb544d299 SHA512 1e78e7c46a028169d65203b00436a62c6822c7a78eb8e1803ae1f681237e73e5b24d68957c64ee8bba47067c05ce3c32f74df951136aa2cfeb2dff9524286052
diff --git a/gui-libs/hyprutils/hyprutils-0.2.0.ebuild b/gui-libs/hyprutils/hyprutils-0.2.0.ebuild
new file mode 100644
index 000000000000..55586fbd00b4
--- /dev/null
+++ b/gui-libs/hyprutils/hyprutils-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Hyprland utilities library used across the ecosystem"
+HOMEPAGE="https://github.com/hyprwm/hyprutils"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ x11-libs/pixman
+"
+RDEPEND="${DEPEND}"