summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 09:30:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 16:50:00 +0100
commitf1b6a4697cb6bd8b01b005cca0996982fd736a2d (patch)
tree9b2799b0df1355e0ee40b8c909752698a0803837 /kde-apps/calendarjanitor
parentapp-emulation/libvirt: init submodules for live ebuild (diff)
downloadgentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.gz
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.bz2
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.zip
kde-apps: Add KDE Applications 18.12.1
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/calendarjanitor')
-rw-r--r--kde-apps/calendarjanitor/Manifest1
-rw-r--r--kde-apps/calendarjanitor/calendarjanitor-18.12.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-apps/calendarjanitor/Manifest b/kde-apps/calendarjanitor/Manifest
index 553e3feb28ed..5747cfd85dba 100644
--- a/kde-apps/calendarjanitor/Manifest
+++ b/kde-apps/calendarjanitor/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-18.08.3.tar.xz 225844 BLAKE2B 7c0e6689049a7bd022cc5b9e1201244997b20b944f9e350e71ea0f9cd7954e2e07a3ebf431c455c925f7180880d127ba590debf16ca2544bfa762efad33ac547 SHA512 f858d8eb2b79b999459d04ccf8e8a05c53c7275b6b3cd2f80224da42f280a4d2a4d6738a235c1f3bb4b40e36d605310cda01097678441b5c4a94698fdf42097d
DIST akonadi-calendar-tools-18.12.0.tar.xz 225048 BLAKE2B 9cd9f65b11a7bf848c246e5ee627e3ec9a7dadc21402e86821d2db9443f9fb8d8fc2763b28dba8fc4bb8b82352d0130e05ff93b804297c68c3c72669200bc2e0 SHA512 e230bd5a71ab10ac7cde4696ce29e46f06011826b581988cc29d5703732dd3be1443f9ec686fafa08fe6c769a5b05d1fc66b5f0fa99aa0c932177ec09f472ef6
+DIST akonadi-calendar-tools-18.12.1.tar.xz 224972 BLAKE2B 069371fa75c1c5c467553fdbc17bb9977a09cc376559ea656f5219ba4911814c0263f157676d289e4064d0afd730c91998cc574a1ce82853f15aba3be904bc38 SHA512 bb9c78c793863a124fdc102a83689550c6d7154fbf3f514cf4fbc3d3cf8a8083d8e4d2f09d55f3b47eda916b2919eab1ee3fd189183080cb45db9802af98445a
diff --git a/kde-apps/calendarjanitor/calendarjanitor-18.12.1.ebuild b/kde-apps/calendarjanitor/calendarjanitor-18.12.1.ebuild
new file mode 100644
index 000000000000..52f7d93122a5
--- /dev/null
+++ b/kde-apps/calendarjanitor/calendarjanitor-18.12.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
+KDE_TEST="false"
+KMNAME="akonadi-calendar-tools"
+inherit kde5
+
+DESCRIPTION="Tool to scan calendar data for buggy instances"
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep kcalcore)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ cmake_comment_add_subdirectory doc konsolekalendar
+ sed -i -e "/console\.categories/ s/^/#DONT/" CMakeLists.txt || die
+
+ # delete colliding konsolekalendar translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/konsolekalendar.po || die
+ rm -rf po/*/docs/konsolekalendar || die
+ fi
+}