summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-07 19:18:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-07 19:18:36 +0200
commit2fb79a4076772020c18be0215abb7a430ac12b3b (patch)
tree02e6972566d0e4e18611dfd81121657a95919e66 /kde-apps/dolphin
parentdev-libs/libinput: Restore version 1.10.6 (diff)
downloadgentoo-2fb79a4076772020c18be0215abb7a430ac12b3b.tar.gz
gentoo-2fb79a4076772020c18be0215abb7a430ac12b3b.tar.bz2
gentoo-2fb79a4076772020c18be0215abb7a430ac12b3b.zip
kde-apps: Add KDE Applications 18.04.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-18.04.2.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 11957d49a3fc..0ca944cfac6d 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-17.12.3.tar.xz 4841752 BLAKE2B 1f58cb0f1663e131a1b8dc58fc47d40a8a68bcb998fd3c6191f99176263523d40c1d9057b569c10c14e2a6b0be91b2eaaf07a54acdd386984d0da167cb84fabd SHA512 44cf8baaeead69dd5529ce7da96d78f507029fa47ac9ac50de9d77cb15335dd0b0e0c916f2cdd0d5cadc465e461115dbfd02c51af38d03da985d66bd22456136
DIST dolphin-18.04.1.tar.xz 4849868 BLAKE2B 3335ced611590b51200135207b5bc5e2266504c7d556e8a903b6f3f63131547369d1fcccce8f13f93f4f15c84e695827ef4deb6088e5ec6219c15f85c140313f SHA512 13c9f45282168a4ae68b9d0977b1734918c662028043167ab36bc67b7b7f1756930a613e7bbd25bafc6db7e1591524f2ec3002247838ddbf0dc49037d4c7a0fd
+DIST dolphin-18.04.2.tar.xz 4850780 BLAKE2B 001fcd1f3fabfe449d5b6ac82763dcba0bfb3aa5303e54b2f72c105521deddd7f0264c435da9471cca5978d69afccb391810c1b6b4ee69f5f66f39034e8e1484 SHA512 760e698903717f30c08d69ae5872b1d42c523d6a554a6570cda6bfbd4fe2c37f2744e461728e7d090cfab6bed0055bf48b8cbb38128503386698f71c5d5f5198
diff --git a/kde-apps/dolphin/dolphin-18.04.2.ebuild b/kde-apps/dolphin/dolphin-18.04.2.ebuild
new file mode 100644
index 000000000000..45f931da6b12
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-18.04.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://www.kde.org/applications/system/dolphin https://userbase.kde.org/Dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ $(add_kdeapps_dep ffmpegthumbs)
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${PN}-18.04.1-flto.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/ark:${SLOT}" ; then
+ elog "For compress/extract and other actions, please install kde-apps/ark:${SLOT}"
+ fi
+
+ if ! has_version "kde-apps/kleopatra:${SLOT}" ; then
+ elog "For crypto actions, please install kde-apps/kleopatra:${SLOT}"
+ fi
+}