summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-21 15:24:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-10 20:34:33 +0200
commite99629355758b234e36463b2394e36b9bd765c70 (patch)
tree3ea21a7ab88f89090fa5233f2e66a2372656f943 /kde-apps/okular
parentRevert "dev-vcs/hg-git-1.1.3: version bump" (diff)
downloadgentoo-e99629355758b234e36463b2394e36b9bd765c70.tar.gz
gentoo-e99629355758b234e36463b2394e36b9bd765c70.tar.bz2
gentoo-e99629355758b234e36463b2394e36b9bd765c70.zip
kde-apps/okular: Fix musl build (implicit vasprintf decl)
KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=398338 Upstream MR: https://invent.kde.org/graphics/okular/-/merge_requests/722 Cherry-picked from upstream's upstream: https://github.com/jlaurens/synctex/commit/4b0590e7d1817b004c71635f9e721edf1e368228 Bug: https://bugs.gentoo.org/922345 Closes: https://bugs.gentoo.org/939431 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/okular')
-rw-r--r--kde-apps/okular/files/okular-23.08.5-implicit-vasprintf.patch29
-rw-r--r--kde-apps/okular/okular-24.05.2.ebuild1
-rw-r--r--kde-apps/okular/okular-24.08.0.ebuild1
3 files changed, 31 insertions, 0 deletions
diff --git a/kde-apps/okular/files/okular-23.08.5-implicit-vasprintf.patch b/kde-apps/okular/files/okular-23.08.5-implicit-vasprintf.patch
new file mode 100644
index 000000000000..685da3112291
--- /dev/null
+++ b/kde-apps/okular/files/okular-23.08.5-implicit-vasprintf.patch
@@ -0,0 +1,29 @@
+From a0f57bf7f984289c5b0ceefa2a784f97cd58428a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Germ=C3=A1n=20Poo-Caama=C3=B1o?= <gpoo@gnome.org>
+Date: Sat, 30 May 2020 16:15:27 -0400
+Subject: [PATCH] Fix implicit declaration of vasprintf
+
+Fix build when compiling with `-Werror=implicit-function-declaration`.
+---
+ core/synctex/synctex_parser.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/core/synctex/synctex_parser.c b/core/synctex/synctex_parser.c
+index 9eed566b3..a67006d39 100644
+--- a/core/synctex/synctex_parser.c
++++ b/core/synctex/synctex_parser.c
+@@ -55,6 +55,11 @@
+ * First level objects are sheets and forms, containing boxes, glues, kerns...
+ * The third tree allows to browse leaves according to tag and line.
+ */
++/* Declare _GNU_SOURCE for accessing vasprintf. For MSC compiler, vasprintf is
++ * defined in this file
++ */
++#define _GNU_SOURCE
++
+ #if defined(SYNCTEX_USE_LOCAL_HEADER)
+ #include "synctex_parser_local.h"
+ #else
+--
+2.44.0
+
diff --git a/kde-apps/okular/okular-24.05.2.ebuild b/kde-apps/okular/okular-24.05.2.ebuild
index ab6d9c0f7283..67a849e10972 100644
--- a/kde-apps/okular/okular-24.05.2.ebuild
+++ b/kde-apps/okular/okular-24.05.2.ebuild
@@ -65,6 +65,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-24.04.80-tests.patch" # bug 734138
"${FILESDIR}/${PN}-20.08.2-hide-mobile-app.patch" # avoid same-name entry
+ "${FILESDIR}/${PN}-23.08.5-implicit-vasprintf.patch" # bug 922345; pending upstream
)
src_configure() {
diff --git a/kde-apps/okular/okular-24.08.0.ebuild b/kde-apps/okular/okular-24.08.0.ebuild
index c39154790f33..6c78b54dae48 100644
--- a/kde-apps/okular/okular-24.08.0.ebuild
+++ b/kde-apps/okular/okular-24.08.0.ebuild
@@ -65,6 +65,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-24.04.80-tests.patch" # bug 734138
"${FILESDIR}/${PN}-20.08.2-hide-mobile-app.patch" # avoid same-name entry
+ "${FILESDIR}/${PN}-23.08.5-implicit-vasprintf.patch" # bug 922345; pending upstream
)
src_configure() {