summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-13 20:20:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-13 20:58:21 +0100
commitb221468d41e59acc045c233359858515491352af (patch)
treeeaa46dab7426306b2b2d77221cd9b64bb34d5a34 /kde-frameworks/kauth
parentkde-frameworks/kactivities: 5.88.0 version bump (diff)
downloadgentoo-b221468d41e59acc045c233359858515491352af.tar.gz
gentoo-b221468d41e59acc045c233359858515491352af.tar.bz2
gentoo-b221468d41e59acc045c233359858515491352af.zip
kde-frameworks/kauth: 5.88.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.88.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index ef486fef9c66..0acb677a2329 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.85.0.tar.xz 88580 BLAKE2B bbb6d0d65c3ee0090ee8c7201938ca92cd59d9fbab84c6051b0937d9a6acd8fa3770f11a4e7cff32662c4d6d98296a58960700a87d9359124719be57f893ecaf SHA512 a775f1952ae112fc80a8119dd7060146dd427da6f73d9d3bb308c9683ffa263949e5f06615bc397806e951cf6156631a3d02505edc390c5982732199f17d812d
DIST kauth-5.87.0.tar.xz 88840 BLAKE2B 6b546b926147ab03400911c5648070ce2651a3b1d4a69b656506498590be91d5fba7d7e7f77bb154d25c2980cc587e24c47f63f1c80954f8c88c087e8be4558d SHA512 4026dbbf5813bdc64519a07be4f1f1946ff77c2eb76d44a8bd43d0ef2d3a8c7504f7ff3fa829b85c3ead900484e7cad9d221d564f2432e372c33a22cb532f453
+DIST kauth-5.88.0.tar.xz 88876 BLAKE2B fdf0535943af84355345d4f67e5f842ccd65d4ae4251eacd5f400d8da5f75d36ab0c685d6ba0440d165d4677618a605a038da6cf2657d064207e90815d27e55b SHA512 8de3f7acc151ed865f8e1f01a2282bf638a1306c6907fac7e85d4a5475fdfd289a8b627544129d83a1aad6af40a3c8febbedee0ab54b7e99c3fb9ff343a8b3f1
diff --git a/kde-frameworks/kauth/kauth-5.88.0.ebuild b/kde-frameworks/kauth/kauth-5.88.0.ebuild
new file mode 100644
index 000000000000..1b89dd9ac255
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.88.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ policykit? ( >=sys-auth/polkit-qt-0.113.0 )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ $(cmake_use_find_package policykit PolkitQt5-1)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ ecm_src_test
+}