summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-04-09 23:05:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-04-09 23:46:05 +0200
commit5813c32d88b52a124d3a8defe5715b6f27628e41 (patch)
treea3dca3fc026ac98d2583dc964392879a3610a1c2 /kde-frameworks/kwallet
parentkde-frameworks/ktextwidgets: 5.93.0 version bump (diff)
downloadgentoo-5813c32d88b52a124d3a8defe5715b6f27628e41.tar.gz
gentoo-5813c32d88b52a124d3a8defe5715b6f27628e41.tar.bz2
gentoo-5813c32d88b52a124d3a8defe5715b6f27628e41.zip
kde-frameworks/kwallet: 5.93.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.93.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index 8f61e425cd11..1831024ba0b1 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.90.0.tar.xz 305148 BLAKE2B 8a462f0e1b7944b6f39341c496f5888d2957d45036341da04ab0f3751ef4687bada3340f8528e695100f81e1cc850f976b8aae960b863e3cf6886112ce807123 SHA512 aa8aa252477881c17abfa266fbf8c928c557bc0cedae123e8290a76bc51ed8c2f0f816fc2f4aba9546ce7c776d0080319faf83567fd38cec022022d0c0982af8
DIST kwallet-5.92.0.tar.xz 305528 BLAKE2B adf94a05ad064a02c5c8cf291014e554f9e432aa07977b08c97b5b61babff53e2e973c16b10ad5ab48cbd7a48b4b3afecabd576070db8076a0cfa2608d7588f1 SHA512 db65cf0e40a758129122e8320b1971e35de5e7a9b65248937e5b3c65063515ce3520ea2f32eb363d138d9c53afae39e2f86618ac318fb19d099a5fa38ac18c6a
+DIST kwallet-5.93.0.tar.xz 305292 BLAKE2B e6b255d01ff045d322db80bbddcf26daee8b9079c5cae494058f8b615b2ca2e42046bbfe23d6e41989bf6bf9fcd8af84619fc955672dcea20787848e7dde43b1 SHA512 925a8ddb10b8c77761b8e34198b3c25d69fd2579adae2ab11ad35ea1cfc810049aac415e873df08ff3caec0a32f09566fdc746105a2fc7a3d09bf1caa495e178
diff --git a/kde-frameworks/kwallet/kwallet-5.93.0.ebuild b/kde-frameworks/kwallet/kwallet-5.93.0.ebuild
new file mode 100644
index 000000000000..a371a605fed0
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.93.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gpg +man"
+
+BDEPEND="
+ man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )
+"
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ gpg? ( >=app-crypt/gpgme-1.7.1:=[cxx,qt5] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after account login" kde-plasma/kwallet-pam
+ optfeature "KWallet management" kde-apps/kwalletmanager:5
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}