summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-09-15 04:04:32 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-09-15 04:12:16 +1000
commit1f9700ed2ec8463a6b7d80a06f83c7b50c973b54 (patch)
tree4a5042f5e2915e29ee83096ce0306f8e0e8208ee /kde-frameworks/solid/solid-5.26.0.ebuild
parentdev-python/simplecv: remove unused patch (diff)
downloadgentoo-1f9700ed2ec8463a6b7d80a06f83c7b50c973b54.tar.gz
gentoo-1f9700ed2ec8463a6b7d80a06f83c7b50c973b54.tar.bz2
gentoo-1f9700ed2ec8463a6b7d80a06f83c7b50c973b54.zip
kde-frameworks: version bump 5.26.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-frameworks/solid/solid-5.26.0.ebuild')
-rw-r--r--kde-frameworks/solid/solid-5.26.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/solid/solid-5.26.0.ebuild b/kde-frameworks/solid/solid-5.26.0.ebuild
new file mode 100644
index 000000000000..df5217299644
--- /dev/null
+++ b/kde-frameworks/solid/solid-5.26.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Provider for platform independent hardware discovery, abstraction and management"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="nls"
+
+RDEPEND="
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ sys-fs/udisks:2
+ virtual/udev
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+ test? ( $(add_qt_dep qtconcurrent) )
+"
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "app-misc/media-player-info" ; then
+ einfo "For media player support, install app-misc/media-player-info"
+ fi
+}