summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-08 13:52:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-08 14:09:42 +0100
commit987eac2881338ff157f172c3565ad33b08fa242d (patch)
tree80363bb374d1288c4f2db292b705a229e9b2cd13 /kde-plasma/kinfocenter
parentkde-plasma/khotkeys: 5.24.0 version bump (diff)
downloadgentoo-987eac2881338ff157f172c3565ad33b08fa242d.tar.gz
gentoo-987eac2881338ff157f172c3565ad33b08fa242d.tar.bz2
gentoo-987eac2881338ff157f172c3565ad33b08fa242d.zip
kde-plasma/kinfocenter: 5.24.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.24.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index a3223d34129f..c6163447ecd1 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.23.5.tar.xz 1152396 BLAKE2B f30af8e32a43079cd87b52e5d8180ca58f8d5743fa2f26afbc4f7cf70bbb2260929f7bfc0907d03320ff29fd2440968f14fa8185832052194390bd4581a085e1 SHA512 9cb25087587f3b469178424ee991b1832bed23cabcdfe2fc515fb1824ba618ee0cc7e5cd270f9ca348f90ceac68f5758d0c7d690cc1ae29b5c136995d7a2e684
DIST kinfocenter-5.23.90.tar.xz 716256 BLAKE2B bdf567b597128ad87b2d61fb7c7105e8ceb5ddcfbc2d90d404b231d0cd476be15d8f087ddee6c1df71a5231e799a83a46aca1426ff3a3e8539988384cff3b486 SHA512 2988f7d976dd774decbd2af6b0d52513257ee0d2f19e0aa23127d6e9d7d493e02739663599aac64bb9689a756b667998a4851d0fb7f21f93afbc3a972de1c7dd
+DIST kinfocenter-5.24.0.tar.xz 716592 BLAKE2B f3811248268b4bc047ebbed2f7dd327dee8c58483343fcee615c93279e50e46b7619235d2b814ec26563e9a2ac7d60ea2b11678af004dc62d602c11047f99029 SHA512 0cd75c5aaff3e9c8717bdd8b87965da650e5d4e3dc23f7215008337fc34ecfe52d17a29ddd9756715dc6e85a14dfd84d3915fcd0c89dce772b260a80036d4e8c
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.24.0.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.24.0.ebuild
new file mode 100644
index 000000000000..dd00438ec4c2
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.24.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.90.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutil
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}