summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-02 14:23:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-02 20:38:19 +0200
commit57177728ccfe7040dffd410be8aab1e3730afe3e (patch)
treedd78ebf759e78bf9c2bf566dc48b2a375f453139 /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.25.4 version bump (diff)
downloadgentoo-57177728ccfe7040dffd410be8aab1e3730afe3e.tar.gz
gentoo-57177728ccfe7040dffd410be8aab1e3730afe3e.tar.bz2
gentoo-57177728ccfe7040dffd410be8aab1e3730afe3e.zip
kde-plasma/ksshaskpass: 5.25.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.25.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index fc0e5875cfc9..3f7e2a1c3f46 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,3 +1,4 @@
DIST ksshaskpass-5.24.5.tar.xz 24708 BLAKE2B e6937ec76b6cadff437c77eaceb075d7050e6d3581e64b66c1a07491352e335e63dc58b6655da6f5532919295bfad0e13da6855370b4c0a3c1eacb9698dc1759 SHA512 e4d7358eb213105a4e479eb3c9d229a87d86c4ebda199f486f9952f81dc1e91b43ba30d834907586f9badbb7e2933e44af5713119caa2e3bc060f16936e9a457
DIST ksshaskpass-5.24.6.tar.xz 24712 BLAKE2B b0656c01d4bf3c59461d001c8d7055e4705d9b74f9dba192562f83128d189c07e3b0bba30ef340123092c83100d1ea264ade2583be2219b23a446b4fde70d031 SHA512 6c7af2e9f322a03c9426f4d5ee25b5d7a7f29cc68c6351eb608db43ea61dc5dae26ff43753ea9dae500a5498b56accea750bdae8ed36f37a43da3e302c646afb
DIST ksshaskpass-5.25.3.tar.xz 24908 BLAKE2B 8f27cb8188e65016c0ecdb0ab524f9af2da378f73d9d9976a23471595226a537411cdbf067a0084b31afd76a780e82ed72e6f7f8c200879514d98f8c12c03da6 SHA512 c3532d9b480a697489c1cae824a8ea2efe39ceaafb68d5382b94ae6929c6fcf4c15edc6eac5aa857acd02d11c9ebacf3ff3e3c33508f57d1573778ced04af4e8
+DIST ksshaskpass-5.25.4.tar.xz 24876 BLAKE2B 4df7a84ed47e39c8100e493734777be8104b7e5744bcb0bbdadd1f21ed170bdc024c4a2b3655021b0cc7c9ba383b6ac23b8663573ba9d39a954b0e7403c08c87 SHA512 c1d403a8300ca9805bedfb34a9f2c0cb4000d180e40e1dc2e0859319a5262b654a6d7512abb641887fcb36f27542364ccdf8901923bfd3f8eb1cdeb0dfd7be6c
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.25.4.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.25.4.ebuild
new file mode 100644
index 000000000000..b5fcc31d9ba8
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.25.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.95.0
+QTMIN=5.15.5
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}