summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-07-05 19:12:19 +0200
committerJohannes Huber <johu@gentoo.org>2016-07-05 19:12:32 +0200
commitbaccf7d89000ee1b91dff0a1019da5f12335b878 (patch)
tree85abae9d424c9a8d6981a9b99a5ff89e826c5ff7 /kde-plasma/ksshaskpass
parentwww-apps/icingaweb2: fixing bug 587964 (apache vs apache2 user) (diff)
downloadgentoo-baccf7d89000ee1b91dff0a1019da5f12335b878.tar.gz
gentoo-baccf7d89000ee1b91dff0a1019da5f12335b878.tar.bz2
gentoo-baccf7d89000ee1b91dff0a1019da5f12335b878.zip
kde-plasma: Version bump KDE Plasma 5.7.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.7.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 1c11f869acd1..6d7f3f4b5588 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.5.5.tar.xz 20556 SHA256 8a5c48f50c4449e39dc312ca5d3dc8cec466d2fc6ad4602adf0d41ee3828fc6b SHA512 48018fe6c42e15c5338cba280f05215c6b3e0e9f015641b377f8ab0c00e6e2898e5fb9e463ac044485268378c0f0a6d6d43c4829881fbd9825c4e4dbe0dc8c1a WHIRLPOOL 5fedc473d93f5ffe66c06daff739a096306ba05e3f86c122529514a6786987d950b397f47f988a431cdb67bce2fb61a472f979bb8a7118164056ba561724148a
DIST ksshaskpass-5.6.5.tar.xz 24796 SHA256 6a135876351314b3de565ab6e4d0d5753749045b9789373ffb2c754fd55152e1 SHA512 015437cd478ef3252c93e39fa88179cd383f4d148df64f597f3df9031433f12f4d74bd84ed9df2af4b1e7e24e961fa5d4ecd55624dc9e19ac78f604f5815fae6 WHIRLPOOL e829edeb52dfa76b07f9e54e86d9e773c7646e02edab301c7c893ee04cbd8334f23766df2deadb26eb9f6494cddb815a8054decef515da7f0ad63499c71a54d9
+DIST ksshaskpass-5.7.0.tar.xz 19120 SHA256 8092f20d4a83827f1a7fc2eb28e7ca729b82b6e13a26d341327b9bf15f88604b SHA512 bd0ef863dbceeb88763f5689204aada407b47aa5f6e99c95af7123d7a0d6b1686a44856bd1afea3b3f67e552a009b1c43b907b0b8c1e968780a4cb531a9a1d85 WHIRLPOOL 72eb3b188b8708ca5cc3f06388cf94bd7809d08ba520ab4c45ebee149e1c9c6ec90113a04a50e666935c043c7d0546c9a01440926e9243443476d32ad76851ec
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.7.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.7.0.ebuild
new file mode 100644
index 000000000000..ed1fdbac0d72
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/ksshaskpass"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !net-misc/ksshaskpass
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}