summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-09-21 11:01:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-21 11:03:28 +0200
commitac381e2b1d310bb5a1b44dac48b12a0bdd60e323 (patch)
treea6150cbe4684bb58231ce8bdca957cf81c9a84b4 /kde-plasma
parentapp-shells/nushell: Stabilize 0.96.1 amd64, #939953 (diff)
downloadgentoo-ac381e2b1d310bb5a1b44dac48b12a0bdd60e323.tar.gz
gentoo-ac381e2b1d310bb5a1b44dac48b12a0bdd60e323.tar.bz2
gentoo-ac381e2b1d310bb5a1b44dac48b12a0bdd60e323.zip
kde-plasma/kwayland-integration: add 5.27.11
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.27.11.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 9dee03f7f1d1..e0aa8c5e6d6b 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
+DIST kwayland-integration-5.27.11.tar.xz 25708 BLAKE2B 67fe2d113955b2cdec1c3d621efbe84b2565aa3f22e0d15eb95f1a2bce1a6c7fe87da9c2974d93fb2f1939d92d64d2ab2a2a1db609df5973ded5ac4a02f214cf SHA512 c5f19a03e8161b346dbd89fb0d1b72d7906c19a7d55535878d9d75b7d96025d61808161f6b0ccaf9b5fef1d112f8e0ba1033ce149e42aec2cd261351d5ffb1c9
DIST kwayland-integration-6.1.4.tar.xz 26420 BLAKE2B ee21cbb36234a1abbcbcb915e5e9a073767362a8b9ceb2d2fac450c4fa5e570b1c3ebc3fbc6b8291c6cf96846c747fa0f03e193e3e6462add6e13734e8136ca1 SHA512 0424f308558b3a1612426aeb5c1230617d18430029ce987178d3bcb69d34e2dfd044563fbef4d1d3d24d2a091069416a302ca376d5267f1819a2f1cad0657447
DIST kwayland-integration-6.1.5.tar.xz 26396 BLAKE2B 7394bde4d04cbdb05367c1804e18718da2144c2190889be53f8cf9a20599593f46ab1933d07b6859de82f832cb30ffde4fba363c296799b190394f974e312ea8 SHA512 02ec5089483f466ee51a1a67a523aa8bac60c45b5cb80372a81493b43294fc83735152bbadb043c5b8af484fe29799da662c9bf5261adf3da774af5ce247b5aa
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.27.11.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.27.11.ebuild
new file mode 100644
index 000000000000..430cc1e0db8f
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.27.11.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm flag-o-matic plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="amd64 ~arm arm64 ~loong ppc64 ~riscv x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kwayland-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module IdleTime
+ cmake_comment_add_subdirectory autotests # only contains idletime test
+ cmake_run_in src cmake_comment_add_subdirectory idletime
+ filter-lto # bug 921430
+}