summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-11-07 16:29:10 +0200
committerJimi Huotari <chiitoo@gentoo.org>2024-11-08 01:11:48 +0200
commitb7c717633f005e88b69c28069643a9839b7a3ee2 (patch)
tree81bd6c3d7eb9f8881e133991f070374e85658db7 /lxqt-base
parentlxqt-base/lxqt-menu-data: add 2.1.0 (diff)
downloadgentoo-b7c717633f005e88b69c28069643a9839b7a3ee2.tar.gz
gentoo-b7c717633f005e88b69c28069643a9839b7a3ee2.tar.bz2
gentoo-b7c717633f005e88b69c28069643a9839b7a3ee2.zip
lxqt-base/lxqt-notificationd: add 2.1.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest1
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-2.1.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index b57974f55952..414f34f5ab86 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1,2 +1,3 @@
DIST lxqt-notificationd-1.4.0.tar.xz 61792 BLAKE2B e44c9e80c9fb964547902d242ea0cb5967977e4e9dad1c047daae8dadd105f97fd1cd30c5022511d9ece3c3f1e6fbf74ef79e2a5df2e2725603d3d1151dfb166 SHA512 5ae28b0f49e1e01c8d0fe96f23b961ca962dab33f16025af172777f385d0fd3471c64a7acb78b46e7dc0c370d324a17f10ec9a4c4b3afbde95d47164a5246d0a
DIST lxqt-notificationd-2.0.1.tar.xz 64132 BLAKE2B 55d0c7f785528acde181161c0d0c4f61f952700f90e535d00ab7009d768f8118e54a6ab10a75e3e3dda2def4fc395720de89701e4fc3ec0927aa9bd346c7723c SHA512 c2a532e61129f09dde253f7499485f85088c19f8cc6f5ddfd1949eb9d43b142ee4f3f526b38a70fbe276623c1637398c70470f24bcdbb5597a499354e9840d67
+DIST lxqt-notificationd-2.1.0.tar.xz 65356 BLAKE2B e5a51ca8b380373ff2527c0c4fa0e903ea0cbe510e3587ca997d255e4ae6fce237f4a660ec90c6c5d1591e5213587a5ba5e417116e513c52400fe89efcb97738 SHA512 4bb72c8303161c036febfe88ee2a1b32f24f61d2fe17d86d1077045e7784cf31cade0138f526f49c408402f4b81143af0106093569654dd4d579cbb1dd036808
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.1.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.1.0.ebuild
new file mode 100644
index 000000000000..8c70f75f8ac2
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.1.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-4.1.0
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets]
+ kde-frameworks/kwindowsystem:6
+ >=kde-plasma/layer-shell-qt-6.0:6
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"