summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/eog-plugins
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest3
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.14.1.ebuild64
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.14.2.ebuild66
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.16.0.ebuild66
-rw-r--r--media-gfx/eog-plugins/metadata.xml10
5 files changed, 209 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
new file mode 100644
index 000000000000..ef5926ab4f70
--- /dev/null
+++ b/media-gfx/eog-plugins/Manifest
@@ -0,0 +1,3 @@
+DIST eog-plugins-3.14.1.tar.xz 360472 SHA256 12070173d875d6e9f70d8b918bbf3dfcc5af8c1681e4fabf212dae96b85318f5 SHA512 c5f8d652742e8981385ba7d5742e4de3e49d51e2a7785d57fc15e3e23bff2460866173e8163f3870fc57c6f9ddfd16a0dce0a15ec1d2e7fea336d26c11d55f0a WHIRLPOOL 923f50b565c16c9597510a8c605fb1b300cf4859042e23b8329edfc1415945b21769d1850f3edc883d3e68f4a6c9ccccb3fe369d8fbebf5154a27b0be4ac6beb
+DIST eog-plugins-3.14.2.tar.xz 363836 SHA256 31a33b65cd6452ebeca3821f6eb45caefb83bd5d121dee7cf7e4c139ba065f89 SHA512 b29e0aa247ce7006a339ba4a4352e9dfe0150662f2a40fbdb10ac21daca95bb8c75b921cfad4a57ee783424befd98145a35f2a9b8a0083a9bff3928c157fa058 WHIRLPOOL ecc6d4e3a60b7e00f5bbb955040c2f43eb7e1d309970b2084bd50ac706fe149df50ae8e7ab7d595caca0b4853113bfb7073c5e785560b999c5b7db86bc277746
+DIST eog-plugins-3.16.0.tar.xz 367436 SHA256 6fab1c1e0705fc2b0e4a63caf3ba1c5b64b4eaa1301e4cbc04bb934428b68450 SHA512 f592aa08754a1f2d5f503239b5b68b4d9617aa0a1e5a0afd3b80d5bc11fcd312b219157607ff53d98927b9b63e088009c5bb5181dbbcc71466785780b3339fe9 WHIRLPOOL 564a3cf6f572a50fad2f9772138afb80d6ca5a3b3b5c178183d36a95f7fea23d7bd499751a27a40e449dd340e3fc626e8a0c64b3d7c056e3abec9ff62ae78727
diff --git a/media-gfx/eog-plugins/eog-plugins-3.14.1.ebuild b/media-gfx/eog-plugins/eog-plugins-3.14.1.ebuild
new file mode 100644
index 000000000000..3f7b5f897b00
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.14.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+exif +flickr map +picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ^^ ( $(python_gen_useflags '*') ) )"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.11.4
+ >=x11-libs/gtk+-3.3.8:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ flickr? ( media-gfx/postr )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} == binary ]] && python_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use flickr && plugins="${plugins},postr"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}
diff --git a/media-gfx/eog-plugins/eog-plugins-3.14.2.ebuild b/media-gfx/eog-plugins/eog-plugins-3.14.2.ebuild
new file mode 100644
index 000000000000..04dcd0eea3ec
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.14.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="+exif +flickr map +picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ^^ ( $(python_gen_useflags '*') ) )"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.11.4
+ >=x11-libs/gtk+-3.3.8:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ flickr? ( media-gfx/postr )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} == binary ]] && python_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use flickr && plugins="${plugins},postr"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}
diff --git a/media-gfx/eog-plugins/eog-plugins-3.16.0.ebuild b/media-gfx/eog-plugins/eog-plugins-3.16.0.ebuild
new file mode 100644
index 000000000000..714d7fdc9dd7
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.16.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif +flickr map +picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ^^ ( $(python_gen_useflags '*') ) )"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.15.90
+ >=x11-libs/gtk+-3.14:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ flickr? ( media-gfx/postr )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} == binary ]] && python_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use flickr && plugins="${plugins},postr"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}
diff --git a/media-gfx/eog-plugins/metadata.xml b/media-gfx/eog-plugins/metadata.xml
new file mode 100644
index 000000000000..041a5ae2a66d
--- /dev/null
+++ b/media-gfx/eog-plugins/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="flickr">Enable uploading to Flickr</flag>
+ <flag name="map">Enable world map display using <pkg>media-libs/libchamplain</pkg></flag>
+ <flag name="picasa">Enable uploading to Google's Picasa Web Albums</flag>
+</use>
+</pkgmetadata>