summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/videorbits
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/videorbits')
-rw-r--r--media-gfx/videorbits/Manifest1
-rw-r--r--media-gfx/videorbits/files/videorbits-2.201-libpng15.patch30
-rw-r--r--media-gfx/videorbits/metadata.xml11
-rw-r--r--media-gfx/videorbits/videorbits-2.201.ebuild40
4 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/videorbits/Manifest b/media-gfx/videorbits/Manifest
new file mode 100644
index 000000000000..1d8d885e06cf
--- /dev/null
+++ b/media-gfx/videorbits/Manifest
@@ -0,0 +1 @@
+DIST videorbits-2.201.tgz 648187 SHA256 2d3b7dd906e2e20e2082b5106b92d279d662a8877ec780cac0913c877642d1bb
diff --git a/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch b/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch
new file mode 100644
index 000000000000..e384738b9357
--- /dev/null
+++ b/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch
@@ -0,0 +1,30 @@
+--- src/simple_png_read.c
++++ src/simple_png_read.c
+@@ -92,7 +92,7 @@
+ return -1;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ fprintf(stderr, "simple_png_read: error (internal)\n");
+ png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
+ fclose(fp);
+@@ -226,7 +226,7 @@
+ return -1;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ fprintf(stderr, "simple_png_read_header: error\n");
+ png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
+ fclose(fp);
+--- src/simple_png_write.c
++++ src/simple_png_write.c
+@@ -18,6 +18,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <png.h>
++#include <zlib.h>
+
+ int simple_png_write_rgba(
+ char *filename,
diff --git a/media-gfx/videorbits/metadata.xml b/media-gfx/videorbits/metadata.xml
new file mode 100644
index 000000000000..126edb4e0cd2
--- /dev/null
+++ b/media-gfx/videorbits/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">comparametric</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/videorbits/videorbits-2.201.ebuild b/media-gfx/videorbits/videorbits-2.201.ebuild
new file mode 100644
index 000000000000..51b99c720072
--- /dev/null
+++ b/media-gfx/videorbits/videorbits-2.201.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a collection of programs for creating high dynamic range images"
+HOMEPAGE="http://comparametric.sourceforge.net/"
+SRC_URI="mirror://sourceforge/comparametric/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ sys-libs/zlib
+ media-libs/libpng
+ virtual/jpeg"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README README.MORE )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+
+ sed -i \
+ -e "s:\$(prefix)/images:\$(prefix)/share/${PN}/images:" \
+ images/Makefile.in || die
+
+ sed -i \
+ -e "s:\$(prefix)/lookuptables:\$(prefix)/share/${PN}/lookuptables:" \
+ lookuptables/Makefile.in || die
+}
+
+src_configure() {
+ tc-export CC
+ econf
+}